View Revisions: Issue #5194

Summary 0005194: Is console "editguis" (Quake IV GUI Editor) still supported? If so, currently unusable
Revision 25.03.2020 20:30 by Geep
Description Just looking into this Doom3/Quake IV tool that was provided as part of the Doom3 engine by Raven Software. Reportedly easy to crash, but still OK to generate and iterate simple 2D GUIs. It is still invocable (in TDM 2.07 Win64) from the console by "editguis", and appears as "Quake IV GUI Editor" window.

However, it is unusable from the outset because
- there's no visible mouse cursor (though menus do respond to mouseovers).
- the screen gamma is bleached, requiring reboot to correct.

In 2017, it was reported broken (not necessarily as described above) by stgatilov and freyk in https://forums.thedarkmod.com/index.php?/topic/19212-multiple-render-worlds/&tab=comments#comment-415501

[Sorry, this got reported under Project DarkRadiant, don't know how to change Project setting]
Revision 25.03.2020 20:26 by Geep
Description Just looking into this Doom3/Quake IV tool that was provided as part of the Doom3 engine by Raven Software. Reportedly easy to crash, but still OK to generate and iterate simple 2D GUIs. It is still invocable (in TDM 2.07 Win64) from the console by "editguis", and appears as "Quake IV GUI Editor" window.

However, it is unusable from the outset because
- there's no visible mouse cursor (though menus do respond to mouseovers).
- the screen gamma is bleached, requiring reboot to correct.

In 2017, it was reported broken (not necessarily as described above) by stgatilov and freyk in https://forums.thedarkmod.com/index.php?/topic/19212-multiple-render-worlds/&tab=comments#comment-415501