View Issue Details

IDProjectCategoryView StatusLast Update
0005417DarkRadiantGUIpublic26.11.2020 04:46
ReporterMirceaKitsune Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionnot fixable 
Platformx64OSLinux openSUSEOS VersionRelease
Product Version2.8.0 
Target Version2.9.2Fixed in Version2.9.2 
Summary0005417: Texture Browser and Media Tab texture preview not repainting (in wxGTK 3.0.x)
DescriptionWhen switching between Media and Texture tabs, the GL widget is not refreshed, unless you resize the tabs using the splitter between cam and orthoview.
TagsNo tags attached.

Activities

greebo

greebo

17.11.2020 04:14

administrator   ~0012955

I can confirm this, it happens in Ubuntu 20.10 too. Don't have a clue what might be causing this though.
Bikerdude

Bikerdude

19.11.2020 21:06

reporter   ~0013001

@Greebo, is DR for Linux effected by the config files as much as the windows version? would deleting these so DR create a fresh fix possibly fix the issue..?
greebo

greebo

20.11.2020 02:43

administrator   ~0013002

In this case of widgets not redrawing, I'd lean towards: no, I cannot quite imagine the config files playing any role here.
greebo

greebo

26.11.2020 03:31

administrator   ~0013019

Discussion and findings here: https://forums.thedarkmod.com/index.php?/topic/20663-linux-texture-and-media-browser-gl-windows-not-refreshing/
greebo

greebo

26.11.2020 03:38

administrator   ~0013020

I'll take over this issue and update its description, since it appears to be part of a general problem in wxGTK 3.0.x
greebo

greebo

26.11.2020 04:45

administrator   ~0013021

After adding additional Update() events, the GL windows in the group dialog will start working again as soon as the user switches to another app and back, or resizes the splitter.
I tried adding some artifical Update(), Layout() or SetSashPosition() events, but none of these did anything - so I give up for the moment being.
greebo

greebo

26.11.2020 04:46

administrator   ~0013022

Setting this to closed, but marked as "not fixable" for now.

Related Changesets

DarkRadiant: master 505a16d5

2020-11-26 03:53:12

greebo

Details Diff
0005417: Work around a GL repaint problem happening that seems to be fixed in wxGTK 3.1.3+ Affected Issues
0005417
mod - radiant/ui/common/TexturePreviewCombo.cpp Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File

Issue History

Date Modified Username Field Change
16.11.2020 20:19 MirceaKitsune New Issue
17.11.2020 04:14 greebo Status new => confirmed
17.11.2020 04:14 greebo Note Added: 0012955
19.11.2020 21:06 Bikerdude Note Added: 0013001
20.11.2020 02:43 greebo Note Added: 0013002
26.11.2020 03:31 greebo Note Added: 0013019
26.11.2020 03:31 greebo Summary Texture Browser appears empty until scrolled through => Texture Browser appears empty until scrolled through (in wxGTK 3.0.x)
26.11.2020 03:38 greebo Summary Texture Browser appears empty until scrolled through (in wxGTK 3.0.x) => Texture Browser and Media Tab texture preview not repainting (in wxGTK 3.0.x)
26.11.2020 03:38 greebo Note Added: 0013020
26.11.2020 03:39 greebo Description Updated View Revisions
26.11.2020 04:36 greebo Changeset attached => DarkRadiant master 505a16d5
26.11.2020 04:36 greebo Assigned To => greebo
26.11.2020 04:36 greebo Status confirmed => assigned
26.11.2020 04:36 greebo Target Version => 2.9.2
26.11.2020 04:45 greebo Note Added: 0013021
26.11.2020 04:46 greebo Status assigned => closed
26.11.2020 04:46 greebo Resolution open => not fixable
26.11.2020 04:46 greebo Fixed in Version => 2.9.2
26.11.2020 04:46 greebo Note Added: 0013022