View Issue Details

IDProjectCategoryView StatusLast Update
0005464The Dark ModPhysicspublic07.08.2022 03:08
ReporterBikerdude Assigned Tonbohr1more  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSAll 
Product VersionSVN 
Target VersionTDM 2.11Fixed in VersionTDM 2.11 
Summary0005464: TDM 2.08-2.09 beta 1: uncapped FPS causing weird player physics
DescriptionIf I have uncapped FPS enabled and max frame set to 400 two issues occur -

1. you wont reliable and consistently hear player footsteps while walking.
2. if the player jumps in the air they will hang there in the air for 0.5-1 seconds if the space key is kept pressed.

In you enable vsync or turn off uncapped FPS both of the above issues will resolve themselves.

- https://youtu.be/xJh8v-MrSrk
TagsNo tags attached.

Relationships

related to 0004493 resolvedduzenko Some physics events have changed in 2.05 due to faster fps 
child of 0004409 resolvedduzenko Add an option to lift the 60 fps lock 

Activities

Dragofer

Dragofer

26.12.2020 17:13

developer   ~0013266

Does this happen in 2.08?
Bikerdude

Bikerdude

26.12.2020 18:00

reporter   ~0013282

yes, will add that to the desctiption.
Bikerdude

Bikerdude

06.08.2022 14:38

reporter   ~0015137

Update to this issue, Iv'e been told by Duzenko/Stgatilov not to have the FPS limit set to anything higher than 300. I can confirm this then fixes the issue.

It might be worth setting the max limit to 300 by default for 2.11.
nbohr1more

nbohr1more

07.08.2022 03:07

developer   ~0015140

Rev 16595

Altered the GUI to only offer 300 FPS as the highest value.

Issue History

Date Modified Username Field Change
26.12.2020 12:28 Bikerdude New Issue
26.12.2020 12:30 Bikerdude Description Updated
26.12.2020 17:13 Dragofer Note Added: 0013266
26.12.2020 18:00 Bikerdude Note Added: 0013282
26.12.2020 18:01 Bikerdude Summary TDM 2.09 beta 1: uncapped FPS causing weird player physics => TDM 2.08-2.09 beta 1: uncapped FPS causing weird player physics
12.01.2021 04:23 nbohr1more Relationship added related to 0004493
12.01.2021 04:24 nbohr1more Relationship added child of 0004409
06.08.2022 14:38 Bikerdude Note Added: 0015137
07.08.2022 03:07 nbohr1more Note Added: 0015140
07.08.2022 03:08 nbohr1more Assigned To => nbohr1more
07.08.2022 03:08 nbohr1more Status new => resolved
07.08.2022 03:08 nbohr1more Resolution open => fixed
07.08.2022 03:08 nbohr1more OS Windows => All
07.08.2022 03:08 nbohr1more OS Version 10 =>
07.08.2022 03:08 nbohr1more Fixed in Version => TDM 2.11
07.08.2022 03:08 nbohr1more Target Version => TDM 2.11