DarkRadiant: master a338cdec

Author Committer Branch Timestamp Parent
orbweaver orbweaver master 2021-01-06 20:41:19 master eb1b1523
Changeset Rename GlobalCameraWndManager to CameraWndManager

Remove "Global" from the name to avoid confusion between the class and the
method (which is just "GlobalCamera()"). This reduces the chances of
accidentally writing GlobalCameraWndManager().doSomething() which does compile,
but gives unexpected results (since the method is called on a temporary local
class rather than the global singleton).
mod - radiant/CMakeLists.txt Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiant/camera/CameraSettings.cpp Diff File
mod - radiant/camera/tools/FreeMoveTool.h Diff File
mod - radiant/camera/tools/JumpToObjectTool.h Diff File
mod - radiant/camera/tools/PanViewTool.h Diff File
mod - radiant/textool/TexTool.cpp Diff File
mod - radiant/ui/mainframe/EmbeddedLayout.cpp Diff File
mod - radiant/ui/mainframe/FloatingLayout.cpp Diff File
mod - radiant/ui/mainframe/MainFrame.cpp Diff File
mod - radiant/ui/mainframe/RegularLayout.cpp Diff File
mod - radiant/ui/mainframe/SplitPaneLayout.cpp Diff File
mod - radiant/xyview/GlobalXYWnd.cpp Diff File