View Issue Details

IDProjectCategoryView StatusLast Update
0002132DarkRadiantGUIpublic07.03.2021 19:56
Reporteruser81Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.3.2 
Target Version2.12.0Fixed in Version2.12.0 
Summary0002132: 3D grid feature
DescriptionEvening

I would like to put in a request for the above feature that I've seen in other 3D editors, the blue grid in the background as show in the following image -

http://img690.imageshack.us/img690/4579/stedgarsexternal.jpg

It would make DR a tad easier, when you loose your bearings, where is up/down, left/right etc.

TagsNo tags attached.

Activities

mattn

mattn

21.05.2010 06:41

updater   ~0003015

yes, having an option to activate this in a configurable (grid-)size would be nice

user81

18.07.2010 17:36

  ~0003132

Greebo, I appreciate you dont have a lot of time to work on DR etc, but is there even a remote possibility that this will get added at some point.?
greebo

greebo

19.07.2010 06:33

administrator   ~0003134

Maybe for 1.5.0, but I can't make any promises.

user81

20.07.2010 09:04

  ~0003140

smokin.

user81

02.02.2012 00:49

  ~0004289

Any idea is this will make it into 1.7.2 (1.8.0)..?
AluminumHaste

AluminumHaste

15.02.2012 14:10

updater   ~0004328

Yeah that would be awesome, although looking at the bug list I think he has his plate full.

user81

11.01.2013 09:42

  ~0004999

@Orbweaver, could this feature be added into 1.7.4..?

Related Changesets

DarkRadiant: master 7a0ac7a1

2021-02-05 08:58:26

greebo

Details Diff
0002132: Draw a camera-centered grid snapped to multiples of 32 Affected Issues
0002132
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiant/camera/CamWnd.h Diff File

DarkRadiant: master 26a2adb7

2021-02-05 09:15:33

greebo

Details Diff
0002132: Add preference settings for enabling the camera grid and adjusting its spacing Affected Issues
0002132
mod - install/user.xml Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiant/camera/CameraSettings.cpp Diff File
mod - radiant/camera/CameraSettings.h Diff File

DarkRadiant: master 55fa827b

2021-02-05 09:26:55

greebo

Details Diff
0002132: Add tool item to camera toolbar Affected Issues
0002132
mod - install/ui/camwnd.fbp Diff File
mod - install/ui/camwnd.xrc Diff File
mod - radiant/camera/CamWnd.cpp Diff File
mod - radiant/camera/CameraWndManager.cpp Diff File

DarkRadiant: master 0acd28ce

2021-02-07 19:06:58

greebo

Details Diff
0002132: Set the view position to 0,0,30 when starting a new map Affected Issues
0002132
mod - radiantcore/map/Map.cpp Diff File

DarkRadiant: master b8dbc7d0

2021-02-12 05:40:06

greebo

Details Diff
0002132: Don't draw the grid in lighting mode due to overdraw effects Affected Issues
0002132
mod - radiant/camera/CamWnd.cpp Diff File

DarkRadiant: materialeditor2 9c3d3139

2021-03-07 13:41:17

greebo

Details Diff
0002132: The grid should write to the depth buffer, to allow for better visualisation of objects near the XY plane Affected Issues
0002132
mod - radiant/camera/CamWnd.cpp Diff File

Issue History

Date Modified Username Field Change
03.02.2010 18:58 user81 New Issue
03.02.2010 20:25 Mortem Desino Severity normal => feature
15.02.2010 11:53 greebo Status new => acknowledged
21.05.2010 06:41 mattn Note Added: 0003015
21.06.2010 00:13 user81 Priority normal => high
21.06.2010 00:13 user81 Product Version 1.1.0 => 1.3.2
21.06.2010 04:39 greebo Priority high => normal
18.07.2010 17:36 user81 Note Added: 0003132
19.07.2010 06:33 greebo Note Added: 0003134
20.07.2010 09:04 user81 Note Added: 0003140
02.02.2012 00:49 user81 Note Added: 0004289
15.02.2012 14:10 AluminumHaste Note Added: 0004328
11.01.2013 09:42 user81 Note Added: 0004999
05.02.2021 11:02 greebo Target Version => 2.12.0
05.02.2021 11:02 greebo Assigned To => greebo
05.02.2021 11:02 greebo Status acknowledged => assigned
05.02.2021 11:02 greebo Changeset attached => DarkRadiant master 7a0ac7a1
05.02.2021 11:02 greebo Changeset attached => DarkRadiant master 26a2adb7
05.02.2021 11:02 greebo Changeset attached => DarkRadiant master 55fa827b
05.02.2021 11:02 greebo Status assigned => resolved
05.02.2021 11:02 greebo Resolution open => fixed
05.02.2021 11:02 greebo Fixed in Version => 2.12.0
09.02.2021 17:48 greebo Changeset attached => DarkRadiant master 0acd28ce
12.02.2021 05:50 greebo Changeset attached => DarkRadiant master b8dbc7d0
07.03.2021 19:56 greebo Changeset attached => DarkRadiant materialeditor2 9c3d3139