View Issue Details

IDProjectCategoryView StatusLast Update
0002681The Dark ModCodingpublic11.04.2012 03:41
Reportertels Assigned Tograyman  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.04 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0002681: assertion when loading Heart under Debug builds
DescriptionThe following triggers in game/entity.cpp, around line 9200 in idEntity::OnAddToLocationEntity:

assert(m_objLocations.FindIndex(locationEntPtr) == -1);
TagsNo tags attached.

Activities

grayman

grayman

11.04.2012 02:18

administrator   ~0004459

I uncommented the offending line to see what the root cause was.

The entity "Sam" tries to register itself 9 times in the same frame with the same location entity.

Going upstream, I found that the location entity--using a clip model check--found Sam 9 times w/in its boundaries, all in the same clock tick.

Sam is a ragdoll, so I asked on the forums how many clip models in a ragdoll and I'm expecting to be told "9".

If that's the case, then the assertion is invalid and it can remain commented out.

Then we can close this.
grayman

grayman

11.04.2012 03:41

administrator   ~0004460

Tels had already commented out the offending assert, to keep it quiet.

I added a few comments to explain why the assert shouldn't have been there in the first place.

Issue History

Date Modified Username Field Change
07.03.2011 22:25 tels New Issue
10.04.2012 19:24 grayman Assigned To => grayman
10.04.2012 19:24 grayman Status new => assigned
11.04.2012 02:18 grayman Note Added: 0004459
11.04.2012 03:41 grayman Note Added: 0004460
11.04.2012 03:41 grayman Status assigned => resolved
11.04.2012 03:41 grayman Resolution open => fixed
11.04.2012 03:41 grayman Fixed in Version => TDM 1.08
11.04.2012 03:41 grayman Target Version => TDM 1.08