View Issue Details

IDProjectCategoryView StatusLast Update
0002752The Dark ModAIpublic26.02.2013 15:06
Reporterjoma Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel Centrino Duo 32 bitsOSWindows OS VersionXP SP3
Product VersionTDM 1.05 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0002752: Changing AIs from neutral to enemies during game does not work unless the AIs bump into each other.
DescriptionSuppose the following situation: Two AIs in a map, one from team A, the other from team B. Team A and B set neutral (both ways). If, during game, we change change either:
- One of the AI team property from its neutral team to an enemy team (say, C),
or
- the relation between teams A and B, so now they are enemies,
the AIs won't realize they are enemies unless they bump into each other.

However, if the teams were initially friends rather than neutral, the change is taken straightaway, and if the AI notice each other they'll fight as expected.

If there are more than just 2 AIs, only the ones that crash into each other notice that they are now enemies and fight. The rest do not get involved.
Steps To ReproduceI'm uploading a map with four rooms. Two rooms deal with changing an AI to a new team which is an enemy team. In one room, from a neutral team, in the other from a friend team. Only the latter works well.

The other two rooms deal with changing the relation between teams. In one room, the teams are first neutral, then become enemies. In the other the teams are first friends, then enemies. Only the latter works well.

In each room there's a table with a readable with details about what team each AI belong to, and how the relation between teams has been set up. There's also a lever on each table that changes AI/team relations.
Additional InformationI'm very new to the TDM forum, I'm not sure if this is the best way to report the issue. I'm happy to provide more info if required.
TagsNo tags attached.

Activities

joma

joma

10.05.2011 13:37

reporter  

AI_relations_change.pk4 (33,674 bytes)
tels

tels

12.06.2011 17:45

reporter   ~0003873

Last edited: 12.06.2011 18:00

View 2 revisions

Ok, sorry, I just had a closer look. You are not changing the team (which seems to work), you are changing the relation. Still investigating.

grayman

grayman

20.02.2013 02:45

administrator   ~0005093

Last edited: 20.02.2013 02:46

View 2 revisions

When an AI from team A encounters an AI from team B and they have a neutral relationship, each AI will stop processing the other's visual stims. Changing teams A and B to enemies probably needs to cause everyone on team A to go through their list of who from team B isn't getting their vis stims, and re-enable those stims.

The reason that friend->friend recognize the enemy->enemy change is that friendly AI never disable the vis stims of other friendly AI. This is so they can continue to exchange greetings ad nauseum.

I'm changing the "disable the stim of a neutral AI once I've seen him" function, so that neutrals will be allowed to share greetings. Those changes will probable help the problem described in this issue.

grayman

grayman

26.02.2013 15:06

administrator   ~0005112

This problem was fixed by the changes made to fix issue 0003317.

All rooms now work as they're supposed to.

Thanks for the very professional test map!! Makes debugging easier.

Issue History

Date Modified Username Field Change
10.05.2011 13:37 joma New Issue
10.05.2011 13:37 joma File Added: AI_relations_change.pk4
11.05.2011 05:14 greebo Status new => acknowledged
12.06.2011 13:29 tels Assigned To => tels
12.06.2011 13:29 tels Status acknowledged => assigned
12.06.2011 17:45 tels Note Added: 0003873
12.06.2011 17:45 tels Target Version => TDM 1.07
12.06.2011 18:00 tels Note Edited: 0003873 View Revisions
13.06.2011 10:10 tels Assigned To tels =>
08.07.2011 10:30 tels Status assigned => acknowledged
30.10.2011 07:31 greebo Target Version TDM 1.07 =>
20.02.2013 02:45 grayman Note Added: 0005093
20.02.2013 02:46 grayman Note Edited: 0005093 View Revisions
20.02.2013 02:47 grayman Assigned To => grayman
20.02.2013 02:47 grayman Status acknowledged => assigned
26.02.2013 15:06 grayman Note Added: 0005112
26.02.2013 15:06 grayman Status assigned => resolved
26.02.2013 15:06 grayman Resolution open => fixed
26.02.2013 15:06 grayman Fixed in Version => TDM 2.00
26.02.2013 15:06 grayman Target Version => TDM 2.00