View Issue Details

IDProjectCategoryView StatusLast Update
0002920The Dark ModCodingpublic10.07.2012 20:20
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0002920: Warned AI do not play walk_alerted walk
DescriptionThere is a special walk animation(s) for AI who have been previously alerted and are carrying a weapon (anim walk_alerted). AI who draw their weapon after being warned should be using it, but are not currently.
TagsNo tags attached.

Activities

grayman

grayman

07.12.2011 18:41

administrator   ~0004197

The scripts currently switch from "walk" to "walk_alerted" when an AI draws his weapon. When he sheaths it, the scripts switch back to "walk".

So it should be working.

What's the difference between the two?

Also, "walk_alerted2" is defined in the def files, but not used by the scripts. What's the difference between it and "walk_alerted"?
Springheel

Springheel

13.12.2011 22:42

administrator   ~0004206

Last edited: 13.12.2011 22:44

View 2 revisions

The difference is mostly the position of the right hand...it is gripped in a fist and has some weight behind it. Otherwise the AI is walking with a sword attached to an open hand.

walk_alerted2 is just an alternate version...the code automatically selects randomly between animations that have the same name but a different number.

I'll keep my eye open in the future and see if I can get a saved game with this happening.

Btw, could the same script switch from the regular, standing idle to an idle_alert animation? Currently AI stand with their weapon in an open hand.

grayman

grayman

01.05.2012 21:17

administrator   ~0004511

Is this still a problem, given the recent changes to recognize that a weapon is being held rather than simply attached?
grayman

grayman

10.05.2012 18:30

administrator   ~0004564

Please check this again, given the recent anim changes I did.

I just tested AI walking alert with and without torches, and in both cases the hand holding the weapon was closed, not open.

When standing, the hand remained closed, so it looks like that's also working now.
Springheel

Springheel

12.05.2012 00:43

administrator   ~0004574

I'll keep my eye out for it.
Springheel

Springheel

08.07.2012 00:56

administrator   ~0004701

I was testing with test/cascadetest.map, and this is still an issue. AI who were warned about a murder drew their weapon but they continued to walk around with an open hand.
grayman

grayman

10.07.2012 20:20

administrator   ~0004705

1 – A warned AI now stops and draws his weapon and continues with walk_alerted.
2 – A warned AI no longer responds to a warning with a “Huh?” response.
3 – A warned AI will now respond with an appropriate bark when warned.

rev. 5495:

AlertIdleState.cpp
ObservantState.cpp
State.cpp
SuspiciousState.cpp
AI.h
AI_events.cpp

rev. 13036

tdm_ai_base.script
tdm_ai_vocal_set_base.def
tdm_moveable_weapons.def
tdm_prop_items.def

Issue History

Date Modified Username Field Change
13.11.2011 23:34 Springheel New Issue
13.11.2011 23:34 Springheel Status new => assigned
13.11.2011 23:34 Springheel Assigned To => grayman
13.11.2011 23:35 Springheel Summary Warned AI do not play alert_idle walk => Warned AI do not play walk_alerted walk
13.11.2011 23:35 Springheel Description Updated View Revisions
07.12.2011 18:41 grayman Note Added: 0004197
07.12.2011 18:42 grayman Status assigned => feedback
13.12.2011 22:42 Springheel Note Added: 0004206
13.12.2011 22:42 Springheel Status feedback => assigned
13.12.2011 22:44 Springheel Note Edited: 0004206 View Revisions
01.05.2012 21:17 grayman Note Added: 0004511
10.05.2012 18:30 grayman Note Added: 0004564
12.05.2012 00:43 Springheel Note Added: 0004574
08.07.2012 00:56 Springheel Note Added: 0004701
10.07.2012 20:20 grayman Note Added: 0004705
10.07.2012 20:20 grayman Reproducibility have not tried => always
10.07.2012 20:20 grayman Status assigned => resolved
10.07.2012 20:20 grayman Resolution open => fixed
10.07.2012 20:20 grayman Fixed in Version => TDM 1.08
10.07.2012 20:20 grayman Target Version => TDM 1.08