View Issue Details

IDProjectCategoryView StatusLast Update
0003004The Dark ModAIpublic03.02.2012 19:07
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003004: Rare issue with AI getting stuck at doors
DescriptionI've seen this twice in the past couple months. If an AI is too close to a door when they begin door handling, and they're not the first in line, they'll turn and walk away to a safe distance, giving others room to deal with the door. This is by design. The rare issue is that they don't leave this state and continue with door handling. If they're the first in line, everyone behind them gets blocked.
TagsNo tags attached.

Activities

grayman

grayman

03.02.2012 19:07

administrator   ~0004293

Add another check for leaving the Safe Position state.

rev. 5244:

HandleDoorTask.cpp

Issue History

Date Modified Username Field Change
03.02.2012 18:57 grayman New Issue
03.02.2012 18:57 grayman Status new => assigned
03.02.2012 18:57 grayman Assigned To => grayman
03.02.2012 19:07 grayman Note Added: 0004293
03.02.2012 19:07 grayman Status assigned => resolved
03.02.2012 19:07 grayman Resolution open => fixed
03.02.2012 19:07 grayman Fixed in Version => TDM 1.08