View Issue Details

IDProjectCategoryView StatusLast Update
0003020The Dark ModAIpublic28.12.2018 12:35
ReporterSeriousToni Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0003020: sitting AI not getting up after script call
DescriptionAn AI with the spawnarg "sitting 1" will play the get up animation several times before getting up when using a call script function.

(check sample map)
Steps To ReproduceCreate a sitting AI.
Use a button and give the AI a new target via call script funtion entity.
After calling the script funtion the AI will take several tries to get up finally.
This is only seen by AIs with "sitting 1". Getting up from a path_sit works well.
TagsNo tags attached.

Activities

SeriousToni

SeriousToni

13.02.2012 16:48

reporter  

path.rar (1,691 bytes)

user81

28.03.2018 10:15

  ~0010228

@Grayman, I believe this has been fixed now?
grayman

grayman

28.03.2018 12:41

administrator   ~0010264

don't know
nbohr1more

nbohr1more

19.12.2018 18:36

developer   ~0010978

Sitting fixes in 2.06 and 2.07 likely have fixed this.

I will test.
nbohr1more

nbohr1more

20.12.2018 04:37

developer   ~0010987

The original issue is fixed.

One AI is sinking through the floor after sitting but that's probably a map
issue since this is a pre-Standalone map.
grayman

grayman

28.12.2018 12:35

administrator   ~0011155

In 2.07, nobody falls through the floor.

Issue History

Date Modified Username Field Change
13.02.2012 16:48 SeriousToni New Issue
13.02.2012 16:48 SeriousToni File Added: path.rar
28.03.2018 10:15 user81 Note Added: 0010228
28.03.2018 12:41 grayman Note Added: 0010264
28.03.2018 13:12 user81 Assigned To => user81
28.03.2018 13:12 user81 Status new => assigned
19.12.2018 18:36 nbohr1more Note Added: 0010978
20.12.2018 04:36 nbohr1more Assigned To user81 => grayman
20.12.2018 04:36 nbohr1more Resolution open => fixed
20.12.2018 04:36 nbohr1more Fixed in Version => TDM 2.07
20.12.2018 04:36 nbohr1more Target Version => TDM 2.07
20.12.2018 04:36 nbohr1more Status assigned => resolved
20.12.2018 04:37 nbohr1more Note Added: 0010987
28.12.2018 12:35 grayman Note Added: 0011155