View Issue Details

IDProjectCategoryView StatusLast Update
0003033The Dark ModCodingpublic16.06.2012 19:09
Reportertels Assigned Totaaaki  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003033: map compiler does not respect fms path
DescriptionWhen you compile a map, it is placed in the root, under "FMNAME/maps":
 
 te@te:~/.doom3$ dir storm/maps/test/
 total 228
 drwxr-xr-x 2 te te 128 2012-02-26 19:01 .
 drwxr-xr-x 3 te te 72 2012-02-26 19:01 ..
 -rw-r--r-- 1 te te 140027 2012-02-26 19:01 trigger_messages.cm
 -rw-r--r-- 1 te te 87562 2012-02-26 19:01 trigger_messages.proc

Instead, the files should go under "darkmod/fms/FMNAME/maps/", in this case storm.
TagsNo tags attached.

Relationships

related to 0003125 resolvedtaaaki Revising Framework/FileSystem for clarity 

Activities

grayman

grayman

18.05.2012 23:32

administrator   ~0004590

Any changes should continue to honor this setup:

1 - WIP lives in "Doom 3/mymission/"

2 - start TDM using this command line:

"C:\Program Files (x86)\DOOM 3\TheDarkMod.exe" +set fs_game_base darkmod +set fs_game mymission

3 - in the TDM console, enter

dmap mymap

4 - dmap compiles the map and places the output files in "Doom 3/mymission/maps/"


The "darkmod/fms/" directory isn't involved in any of this.
tels

tels

20.05.2012 20:26

reporter   ~0004596

We have been talking about removing support for loading things from "doom3/mymission" completely because it can hit people ater upgrading (when there are left-over files there that interfere). Just saying.
grayman

grayman

20.05.2012 20:34

administrator   ~0004597

That's been my work setup for the past 2 years, and I remember it as described/recommended on the wiki. It keeps my work separate from the darkmod folder.

Does the command line then need to change to:

"C:\Program Files (x86)\DOOM 3\TheDarkMod.exe" +set fs_game_base darkmod +set fs_game darkmod\fms\mymission

and will TDM and dmap understand that?
tels

tels

21.05.2012 11:40

reporter   ~0004602

Last edited: 21.05.2012 11:42

View 2 revisions

No, as far as I understand, you would use "+set fs_game mymission" as usual, but things are now always located in "darkmod/fms/mymission" (the PK4, savegames etc are already all loaded from there, and the map compiler now puts the .lin file there, too).

Basically, instead of using "doom3/" as "base", it will use "where_ever_tdm_is_installed/darkmod/fms" as base and then append the "mymission/".

The reason is that:

* putting arbitrary folders under "doom3/" can conflict with other mods (this becomes less a problem if TDM goes standalone)
* reading things from "doom3/mymission" has a high chance to pick up things left-over from old installations
* putting things into "doom3/mymission" can fail if this directory isn't even there (the mission is installed under "darkmod/fms/mymission" by default)
* putting things into "doom3/mymission" can confuse (there are now two locations to look for things)

taaaki

taaaki

16.06.2012 19:09

administrator   ~0004666

Should be resolved in Revision 5479.

Issue History

Date Modified Username Field Change
26.02.2012 18:11 tels New Issue
09.05.2012 19:21 taaaki Relationship added related to 0003125
18.05.2012 23:32 grayman Note Added: 0004590
20.05.2012 20:26 tels Note Added: 0004596
20.05.2012 20:34 grayman Note Added: 0004597
21.05.2012 11:40 tels Note Added: 0004602
21.05.2012 11:41 tels Assigned To => taaaki
21.05.2012 11:41 tels Status new => assigned
21.05.2012 11:41 tels Target Version => TDM 1.08
21.05.2012 11:42 tels Note Edited: 0004602 View Revisions
16.06.2012 19:09 taaaki Note Added: 0004666
16.06.2012 19:09 taaaki Status assigned => resolved
16.06.2012 19:09 taaaki Fixed in Version => TDM 1.08
16.06.2012 19:09 taaaki Resolution open => fixed