View Issue Details

IDProjectCategoryView StatusLast Update
0003048The Dark ModCodingpublic06.03.2012 22:50
ReporterBaddcog Assigned Totels  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003048: coding for target spawn entity
Description Need support for targetting an attached entity.

ie: mapper added lever base entity to map. Links base to lamp.

 base spawns attached lever entity, spawned entity works on lamp in game.

 possibly frob/peer link? So player actually frobs base plate but base plate and lever both highlight/vice-versa.
Additional Information Could be useful for many items.

 switch model combos, machines with switch, lamps with switch, chests with lids and levers (might solve rotation issues for authors),
TagsNo tags attached.

Relationships

related to 0003051 new Targeting a bind children causes endless "trigger" loops 

Activities

tels

tels

05.03.2012 20:16

reporter   ~0004372

The "add_link" spawnarg supports this, but an additional difficulty is that when defined inside an entityDef, the name of the currently created entity is not yet know (until it is actually spawned).

Technically, it is possible to give a spawned entity a name - the "world" entity does this. However, names must be unique, and you could never spawn more than one entity that way. So this cannot be used.

The add_link spawnarg can technically use the "self" entity when you leave the name off, so "add_link :attached:flame to " would correctly find the attached flame on the "" entity (e.g. itself) and link it to "" (e.g. itself), however, this syntax is quite wierd.

So adding support for "self:attached:flame to self" is definitely needed.
tels

tels

05.03.2012 23:03

reporter   ~0004373

The code change is in and there is an example entity and a testmap. However, the lever does send a signal to the light, which in turn sends a signal back to the lever, which induces a flip-flop loop. That needs to be dealt with, probably in the tdm_light_holder script object.
tels

tels

06.03.2012 22:50

reporter   ~0004376

The trigger loop is dealt with in the tdm_light_holder script, so apart from possible trigger loops in attached-and-bound-at-the-same-time movers, this works as intended now. Lamps with auto-attached levers/switches are now possible ;)

Issue History

Date Modified Username Field Change
05.03.2012 19:53 Baddcog New Issue
05.03.2012 19:53 Baddcog Status new => assigned
05.03.2012 19:53 Baddcog Assigned To => tels
05.03.2012 20:16 tels Note Added: 0004372
05.03.2012 20:16 tels Severity normal => feature
05.03.2012 23:03 tels Note Added: 0004373
06.03.2012 07:20 tels Relationship added related to 0003051
06.03.2012 22:50 tels Note Added: 0004376
06.03.2012 22:50 tels Status assigned => resolved
06.03.2012 22:50 tels Fixed in Version => TDM 1.08
06.03.2012 22:50 tels Resolution open => fixed