View Issue Details

IDProjectCategoryView StatusLast Update
0003087The Dark ModAnimationpublic23.05.2012 21:31
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 1.08 
Summary0003087: Archer "snaps" from turning animation to combat_idle
DescriptionLooks like there are missing frames or something.

1. Throw an object at a friendly archer.

2. He will go into idle_combat and look around to see who threw it.

3. After he is finished turning, he snaps to combat idle with a clear jump.

TagsNo tags attached.

Activities

Springheel

Springheel

18.04.2012 17:43

administrator   ~0004479

grayman: I see this also in the "warm hands" animation. There's a snap from the standing idle animation and the beginning of the "warm hands", and also a snap back to idle when "warm hands" ends.
Springheel

Springheel

18.04.2012 19:13

administrator   ~0004481

Inventor does the same thing?
Springheel

Springheel

28.04.2012 23:12

administrator   ~0004500

Looks like all civilians and archers have this problem. Something to do with not using the same combat idle animation as other AI.
Springheel

Springheel

03.05.2012 19:01

administrator   ~0004522

Did someone address this already? I just tried to reproduce it by throwing things at AI and could not.
Springheel

Springheel

03.05.2012 19:09

administrator   ~0004523

Last edited: 03.05.2012 20:32

View 3 revisions

Ok, got it to happen with the archer, but only when his bow was already drawn and he was playing his alert idle. If he was just standing idle, the snapping doesn't happen.

This has nothing to do with hitting AI with objects...the archer will do it even during a general search if he turns using the turn animation.

Unfortunately, I have no good idea where I should go to explore this problem.

Springheel

Springheel

03.05.2012 22:50

administrator   ~0004525

Hmm, all the turning animations seem to have a blendframes value of 0, unlike all the other animations. Changed this to 4 and will see if it has any impact.
Springheel

Springheel

04.05.2012 01:05

administrator   ~0004528

That seems to have gotten rid of the "snapping". I don't fully understand the values I changed, so we'll have to keep an eye out for any unforseen consequences.

Issue History

Date Modified Username Field Change
18.04.2012 15:21 Springheel New Issue
18.04.2012 15:21 Springheel Status new => assigned
18.04.2012 15:21 Springheel Assigned To => Springheel
18.04.2012 17:43 Springheel Note Added: 0004479
18.04.2012 19:13 Springheel Note Added: 0004481
28.04.2012 23:12 Springheel Note Added: 0004500
03.05.2012 19:01 Springheel Note Added: 0004522
03.05.2012 19:09 Springheel Note Added: 0004523
03.05.2012 20:32 Springheel Note Edited: 0004523 View Revisions
03.05.2012 20:32 Springheel Note Edited: 0004523 View Revisions
03.05.2012 22:50 Springheel Note Added: 0004525
04.05.2012 01:05 Springheel Note Added: 0004528
04.05.2012 01:05 Springheel Status assigned => feedback
23.05.2012 21:31 Springheel Status feedback => resolved
23.05.2012 21:31 Springheel Resolution open => fixed