View Issue Details

IDProjectCategoryView StatusLast Update
0003130The Dark ModDef / Setuppublic18.05.2012 17:41
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003130: Logs in fireplace entities do not switch skin when extinguished
DescriptionWhen you extinguish a fire in one of the fireplace entities, the logs stay with their lit skin instead of switching to tdm_burnt_logs.
TagsNo tags attached.

Activities

grayman

grayman

18.05.2012 14:24

administrator   ~0004584

I've confirmed that the skin is being set properly to tdm_burnt_logs and not accidently being set back to burning logs, or being skipped.

The dds texture used is correct: burnt logs with no glowing embers.

The script successfully tells the DLL to make the change, and the DLL successfully tells the renderer. Everything appears correct at the point it's passed to the renderer.

So at this point I'm not sure what's going wrong.

Will continue looking.
grayman

grayman

18.05.2012 16:48

administrator   ~0004585

This problem stemmed from an incorrect skin definition in tdm_fireplace.skin for the burnt logs.

Corrected and tested, but now I'm having SVN checkin problems due to something wrong at my end.

Back l8r.
grayman

grayman

18.05.2012 17:41

administrator   ~0004587

Fixed in rev 12884.

Corrected skin replacements in skin 'tdm_burnt_logs', in tdm_fireplace.skin.

Issue History

Date Modified Username Field Change
17.05.2012 01:03 Springheel New Issue
18.05.2012 13:39 grayman Assigned To => grayman
18.05.2012 13:39 grayman Status new => assigned
18.05.2012 14:24 grayman Note Added: 0004584
18.05.2012 16:48 grayman Note Added: 0004585
18.05.2012 16:48 grayman Description Updated View Revisions
18.05.2012 17:41 grayman Note Added: 0004587
18.05.2012 17:41 grayman Status assigned => resolved
18.05.2012 17:41 grayman Resolution open => fixed
18.05.2012 17:41 grayman Product Version TDM 1.08 => SVN
18.05.2012 17:41 grayman Fixed in Version => TDM 1.08
18.05.2012 17:41 grayman Target Version => TDM 1.08