View Issue Details

IDProjectCategoryView StatusLast Update
0003216The Dark ModAIpublic28.03.2018 16:25
Reporteruser81Assigned Tostgatilov  
PriorityhighSeveritycrashReproducibilityrandom
Status resolvedResolutionunable to reproduce 
PlatformWin32OSWindowsOS Version7 sp1
Product VersionTDM 1.07 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0003216: Enabling EAX on very large maps caused BSOD
DescriptionI found a serious bug that's been around since 1.07, I'm not 100% sure if its TDM/D3 or Creative that's the root cause though.
I have only had this happen to me on very big maps, in fact the two biggest maps ever and that's Restless and now Blackheart manor. While in-game flying around in noclip checking for things to fix my PC BSOD'd. I examined the memory dump and its once again pointed at " ctoss2k.sys ( ctoss2k+5cea ) ". The only fix I found for this when working on Restless was to turn off EAX.

I have been working on the training map all day and other maps the rest of the week with EAX on and its been fine, so it would seem to suggest very large maps and EAX are causing some sort of conflict
Steps To ReproduceLoad Blackheart manor and after a while you'll get a BSOD.
TagsNo tags attached.

Activities

grayman

grayman

27.10.2012 16:53

administrator   ~0004926

And BSOD stands for ?
nbohr1more

nbohr1more

14.09.2017 03:18

developer   ~0009222

EAX has been replaced by EFX \ OpenAL in TDM 2.06.
Is this still replicable?
nbohr1more

nbohr1more

19.09.2017 16:29

developer   ~0009303

Closing for now. Sound has been completely reworked in 2.06.
Reopen if anything is found in beta.

user81

28.03.2018 16:25

  ~0010316

Just an update on this, EFX is working perfectly on Large to small maps.

Issue History

Date Modified Username Field Change
01.09.2012 10:02 user81 New Issue
05.09.2012 05:36 greebo Project DarkRadiant => The Dark Mod
27.10.2012 16:53 grayman Note Added: 0004926
14.09.2017 03:17 nbohr1more Assigned To => stgatilov
14.09.2017 03:17 nbohr1more Status new => feedback
14.09.2017 03:17 nbohr1more Category General => AI
14.09.2017 03:17 nbohr1more Product Version => TDM 1.07
14.09.2017 03:17 nbohr1more Target Version => TDM 2.06
14.09.2017 03:18 nbohr1more Note Added: 0009222
19.09.2017 16:29 nbohr1more Note Added: 0009303
19.09.2017 16:29 nbohr1more Status feedback => resolved
19.09.2017 16:29 nbohr1more Resolution open => unable to reproduce
19.09.2017 16:29 nbohr1more Fixed in Version => TDM 2.06
28.03.2018 16:25 user81 Note Added: 0010316