View Issue Details

IDProjectCategoryView StatusLast Update
0003323The Dark ModAIpublic26.02.2013 14:31
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003323: Need support for AI greeting pagans and beggars
DescriptionSome vocal sets have special greetings given to pagans and beggars ("snd_greeting_beggar"). Currently, pagans and beggars are neutral to everyone, and thus no greetings are given.
TagsNo tags attached.

Activities

Springheel

Springheel

20.02.2013 00:58

administrator   ~0005091

"snd_greeting_pagan" also exists.

Also, there are vocals for beggars to ask passerbys for money...that probably also won't happen since they are neutral to everyone else.

Maybe it would be better to just let neutrals greet each other?
grayman

grayman

20.02.2013 02:32

administrator   ~0005092

I think I should start with letting a pair of AI with a neutral relationship exchange greetings and we'll see if more tweaking is needed after listening for a while. This at least will get us the barks we haven't been hearing.
grayman

grayman

26.02.2013 01:35

administrator   ~0005110

The changes for issue 0003317 included greeting neutrals, so the basics are in place.

I need to get the code to use snd_greeting_beggar.

Let me know if other work is needed for this issue.
grayman

grayman

26.02.2013 14:31

administrator   ~0005111

Support for AIs greeting neutral AIs was added as part of the fix to 0003317.

Gave beggars PERSONTYPE_BEGGAR and added code for AIs to bark snd_greetings_beggar.

rev. 5701:

State.cpp

Rev 13336:

tdm_ai_townsfolk_beggar.def

Issue History

Date Modified Username Field Change
20.02.2013 00:49 Springheel New Issue
20.02.2013 00:58 Springheel Note Added: 0005091
20.02.2013 02:32 grayman Note Added: 0005092
20.02.2013 02:32 grayman Assigned To => grayman
20.02.2013 02:32 grayman Status new => assigned
26.02.2013 01:35 grayman Note Added: 0005110
26.02.2013 14:31 grayman Note Added: 0005111
26.02.2013 14:31 grayman Status assigned => resolved
26.02.2013 14:31 grayman Resolution open => fixed
26.02.2013 14:31 grayman Fixed in Version => TDM 2.00
26.02.2013 14:31 grayman Target Version => TDM 2.00