View Issue Details

IDProjectCategoryView StatusLast Update
0003345The Dark ModCodingpublic30.03.2013 01:08
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00 
Summary0003345: Flame based lights not working in Standalone TDM
Descriptionhttp://forums.thedarkmod.com/topic/14572-playing-standalone/#entry307002

The lamps had the right texture and a glow particle around them, but no light was cast.

I copied all the missing files from Doom3/glprogs to our folder, but it didn't change anything about the light.

If it's helpful, regular, default lights seem to work. Nothing that uses a flame, however, whether candle, torch, etc, casts any light. And while normal ambient lights appear to work, the world ambient does not. The player lantern works normally.
TagsNo tags attached.

Activities

grayman

grayman

14.03.2013 21:15

administrator   ~0005178

Is this now fixed by my reverting the sound change that kept sounds from starting until the frame counter had moved off of zero?
Springheel

Springheel

15.03.2013 02:30

administrator   ~0005185

I'll have to test it, but the problem wasn't limited to lights with a soundshader, so I wouldn't assume so.
Springheel

Springheel

15.03.2013 14:28

administrator   ~0005187

Just tested and no, there's no change here.
grayman

grayman

29.03.2013 22:22

administrator   ~0005263

I ran Chalice in a standalone setup.

I noticed this in the console output:

WARNING:Couldn't load image: makeintensity( lights/squarelight1a)

I checked darkmod/lights and there was no image named "squarelight1a"

I copied base/lights/squarelight1a.tga to darkmod/lights and that fixed the problem in Chalice's starting courtyard, both for the wall torches and the electric light over the door. Going inside, the long hallway's lights now work properly.

Since this is a direct copy of a D3 asset to TDM, I'm not sure how you want to handle it. Because of that, I did not check in the missing file.
Springheel

Springheel

30.03.2013 00:27

administrator   ~0005265

Well damn, how the heck did I miss that?

I've made a new version, and things seem to be working now, thanks.

Issue History

Date Modified Username Field Change
11.03.2013 16:29 Springheel New Issue
14.03.2013 21:15 grayman Note Added: 0005178
15.03.2013 02:30 Springheel Note Added: 0005185
15.03.2013 14:28 Springheel Note Added: 0005187
29.03.2013 22:22 grayman Note Added: 0005263
30.03.2013 00:27 Springheel Note Added: 0005265
30.03.2013 01:08 Springheel Status new => resolved
30.03.2013 01:08 Springheel Resolution open => fixed
30.03.2013 01:08 Springheel Assigned To => Springheel