View Issue Details

IDProjectCategoryView StatusLast Update
0003372The Dark ModAIpublic16.10.2017 21:54
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003372: AI not playing pain animation
DescriptionAI don't seem to be playing the pain animation when hit with arrows anymore. Not sure when this happened.
TagsNo tags attached.

Relationships

related to 0003442 closedgrayman AI do not play pain animation when enemy out of reach 

Activities

grayman

grayman

14.04.2013 17:20

administrator   ~0005296

What was the AI doing when hit?

Searching?

Combat mode?

Hit by player or hit by an archer AI?

Which AI?
Springheel

Springheel

14.04.2013 21:13

administrator   ~0005298

Last edited: 14.04.2013 21:30

View 2 revisions

Several AI and several different states. I can't get any of them to play a pain animation.

grayman

grayman

14.04.2013 22:17

administrator   ~0005299

AI won't play pain anims when in combat mode, because they mess up the combat anims.

The AI that weren't playing pain anims were transitioning into combat mode (because they were hit by an arrow and could see their attacker). The check for playing a pain anim occurred afterward. By moving the pain anim check forward of the combat state entry, the AI will play the pain anim.

Rev. 5737:

AI.cpp

Issue History

Date Modified Username Field Change
13.04.2013 01:24 Springheel New Issue
14.04.2013 17:20 grayman Note Added: 0005296
14.04.2013 17:20 grayman Assigned To => grayman
14.04.2013 17:20 grayman Status new => assigned
14.04.2013 21:13 Springheel Note Added: 0005298
14.04.2013 21:30 Springheel Note Edited: 0005298 View Revisions
14.04.2013 22:17 grayman Note Added: 0005299
14.04.2013 22:17 grayman Status assigned => resolved
14.04.2013 22:17 grayman Resolution open => fixed
14.04.2013 22:17 grayman Fixed in Version => TDM 2.00
14.04.2013 22:17 grayman Target Version => TDM 2.00
16.10.2017 21:54 nbohr1more Relationship added related to 0003442