View Issue Details

IDProjectCategoryView StatusLast Update
0003375The Dark ModAIpublic14.04.2013 17:18
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003375: Sleeping Builder in Outpost not sleeping
DescriptionThe Builder who should be sleeping in bed on the first floor is instead standing beside the bed now on map start. Possible result of recent changes to sleep code to fix falling through floor issue?
TagsNo tags attached.

Activities

grayman

grayman

14.04.2013 04:31

administrator   ~0005292

Last edited: 14.04.2013 04:37

View 2 revisions

My test sleepers for those changes all got into bed just fine. The test included the notorious barracks sleeper in Beleaguered. Both he and his friend climbed into bed w/o problems.

Post here if any other sleepers have problems. Hopefully it's just something specific to the Outpost sleeper.

Edit: Checked Outpost and my sleepers test map. Everybody's snoring while standing up. This tells me it's the animation not getting a chance to run, so it's most likely caused by the changes I made to help AI stand up properly while sitting. I didn't test sleeping after those changes, because they had nothing to do with sleeping. Guess they do, somehow.

Will look at this tomorrow.

grayman

grayman

14.04.2013 17:18

administrator   ~0005295

This was caused by a mistake in the fix for issue 0003009.

rev. 13409:

tdm_ai_base.script

Issue History

Date Modified Username Field Change
14.04.2013 02:46 Springheel New Issue
14.04.2013 04:31 grayman Note Added: 0005292
14.04.2013 04:32 grayman Assigned To => grayman
14.04.2013 04:32 grayman Status new => assigned
14.04.2013 04:37 grayman Note Edited: 0005292 View Revisions
14.04.2013 17:18 grayman Note Added: 0005295
14.04.2013 17:18 grayman Status assigned => resolved
14.04.2013 17:18 grayman Resolution open => fixed
14.04.2013 17:18 grayman Fixed in Version => TDM 2.00