View Issue Details

IDProjectCategoryView StatusLast Update
0003397The Dark ModSoundpublic11.05.2013 00:08
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003397: Stange sound distortion in Let Sleeping Thieves Lie
DescriptionIn TDM 2.0, there is a weird VERY loud static sound playing throughout the inn. It seems to be loudest in the upstairs hallway.

It's strange because there are NO speaker entities anywhere near the inn. Must be some kind of location sound based around info_locationseparator_7?

 
TagsNo tags attached.

Activities

grayman

grayman

10.05.2013 00:48

administrator   ~0005382

Last edited: 10.05.2013 03:46

View 2 revisions

I can reproduce this now with standalone 2.0.

Springheel

Springheel

10.05.2013 01:32

administrator   ~0005385

Last edited: 10.05.2013 01:33

View 2 revisions

Well that's disconcertingly strange. Although the 1.08 version of the map does not have that sound on my computer, so that suggests some possible problem caused by 2.0.

grayman

grayman

10.05.2013 03:45

administrator   ~0005394

Given my mistake on the drowning death, I retested this mission and now I hear the nasty static on the second floor of the inn.

So it has nothing to do with sound cards or whatever; it's a problem with a sound in the mission.
Springheel

Springheel

10.05.2013 17:46

administrator   ~0005397

Someone reported another unusual sound in a mission also using an info_locationseparator entity. May be a connection.
grayman

grayman

10.05.2013 17:53

administrator   ~0005398

What mission, and where in the mission?
grayman

grayman

10.05.2013 19:28

administrator   ~0005399

Last edited: 10.05.2013 19:29

View 2 revisions

I checked the location entities and they don't use suspect sounds, and the inn and the street are both in the same location, and we don't hear the static in the street.

The problem is the gas lamp used in the inn. There are four of them, and they use this:

s_shader teleport_machine_idle

I don't see anything wrong with the sound definition, but I copied the four lamps to an empty map, started it up, and was flooded with the nasty static.

So there's something about that sound or the way it's used that's causing a problem. I haven't opened the ogg file in a sound editor yet; perhaps it's corrupt.

The lamp in question is atdm:lamp_gaslight_lit, which doesn't use this shader as a default. The mapper added the spawnarg to the lights.

Springheel

Springheel

10.05.2013 19:29

administrator   ~0005401

Last edited: 10.05.2013 19:30

View 2 revisions

Ah, ok, good catch. I wonder if it's an issue of using an .ogg when it needs to be a .wav? I'll look into it. It's a bit curious that gas lamps with flames are using a s_shader at all....

grayman

grayman

10.05.2013 21:25

administrator   ~0005402

If you look at the collection of gas lamps, you'll see that sound shader on a subset of them.

I suppose someone wanted them to have a hissing gas sound.
Springheel

Springheel

10.05.2013 21:39

administrator   ~0005403

Last edited: 10.05.2013 21:40

View 2 revisions

I don't quite understand what's going on. The soundshader values were copied directly from D3, but they seem extremely loud:

teleport_machine_idle {

    minDistance 10
    maxDistance 30
    volume 10
    //looping

    sound/ed/sfx/teleporter/tele_idle.wav

}

The actual sound file is not much louder than the original. Given a radius of 30 and a volume of 10, I would expect the sound to be quite loud, yet it's not in 1.08. Puzzling.

grayman

grayman

10.05.2013 21:59

administrator   ~0005404

If that's the D3 definition, it comments out the looping line.

Ours doesn't.

Should that matter?
Springheel

Springheel

10.05.2013 22:56

administrator   ~0005405

I just ran the map again in 1.08 and stood right next to the lights in the inn. I couldn't hear any hissing at all.

Ahh...could it be that the sound WOULD have been super loud if it had been looping, but because the original D3 had that commented out, the sound just played once and then stopped?
grayman

grayman

10.05.2013 23:18

administrator   ~0005406

I think you nailed it.

When I take our sound shader and comment out the looping line, I hear nothing at the gas lamps.

So now I can't hear hissing in 1.08 or 2.0.

I would just comment the looping line and leave it at that. Wrt those lamps, the mission would then play the same in 1.08 or 2.0. It's not what the map authors wanted, I'm sure, but I guess they didn't notice the lack of hiss in 1.08.
Springheel

Springheel

10.05.2013 23:46

administrator   ~0005407

Yes, I'll do that, and make an alternate looping soundshader for future use.
grayman

grayman

11.05.2013 00:08

administrator   ~0005408

When I loop that sound in a sound editor, it no way sounds like hissing gas.

It sounds like an electrical machine hum.

Issue History

Date Modified Username Field Change
04.05.2013 13:24 Springheel New Issue
10.05.2013 00:48 grayman Note Added: 0005382
10.05.2013 01:32 Springheel Note Added: 0005385
10.05.2013 01:33 Springheel Note Edited: 0005385 View Revisions
10.05.2013 03:45 grayman Note Added: 0005394
10.05.2013 03:46 grayman Note Edited: 0005382 View Revisions
10.05.2013 17:46 Springheel Note Added: 0005397
10.05.2013 17:53 grayman Note Added: 0005398
10.05.2013 19:28 grayman Note Added: 0005399
10.05.2013 19:29 grayman Note Edited: 0005399 View Revisions
10.05.2013 19:29 Springheel Note Added: 0005401
10.05.2013 19:29 Springheel Assigned To => Springheel
10.05.2013 19:29 Springheel Status new => assigned
10.05.2013 19:30 Springheel Note Edited: 0005401 View Revisions
10.05.2013 21:25 grayman Note Added: 0005402
10.05.2013 21:39 Springheel Note Added: 0005403
10.05.2013 21:40 Springheel Note Edited: 0005403 View Revisions
10.05.2013 21:59 grayman Note Added: 0005404
10.05.2013 22:56 Springheel Note Added: 0005405
10.05.2013 23:18 grayman Note Added: 0005406
10.05.2013 23:46 Springheel Note Added: 0005407
10.05.2013 23:46 Springheel Status assigned => resolved
10.05.2013 23:46 Springheel Fixed in Version => TDM 2.00
10.05.2013 23:46 Springheel Resolution open => fixed
11.05.2013 00:08 grayman Note Added: 0005408