View Issue Details

IDProjectCategoryView StatusLast Update
0003401The Dark ModDef / Setuppublic10.05.2013 21:27
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Fixed in VersionTDM 2.00 
Summary0003401: Drowning broken?
DescriptionNo idea why I tested this cuz I've never done it before; I jumped into the water and decided to stay under until my breath ran out, and - it didn't cause any damage. Tested it in 1.08 and it did. Not a major issue in this map (you'd have to be spectacularly inept to get trapped underwater in this one) but may be worth checking in others.

Possibly a missing damage def?
TagsNo tags attached.

Activities

grayman

grayman

10.05.2013 00:00

administrator   ~0005379

I just tried this in your test map, the one with all the different AI in it, and the pool of water in the corner.

Jumped in, watched the breath gauge go down, then when it emptied, watched the health gauge go down, accompanied by the gagging sounds and the red overlay. When that gauge emptied, I died and was taken to the Skull screen.

What map were you playing? Perhaps there's a difference in the definitions on the water entity.
Springheel

Springheel

10.05.2013 00:20

administrator   ~0005380

This was a report from Too Late.
grayman

grayman

10.05.2013 00:41

administrator   ~0005381

I jumped into the Too Late water and had the same death experience.

Perhaps something didn't get downloaded in the tester's SVN DL.
Springheel

Springheel

10.05.2013 01:34

administrator   ~0005386

Weird.
Springheel

Springheel

10.05.2013 01:38

administrator   ~0005387

Last edited: 10.05.2013 01:46

View 4 revisions

I just tested it, and confirmed the report. No damage when the air bar disappeared. There was a warning message in the console about a missing "noair" damage entity.... how could it be working for you?

edit: I can probably just fix this by copying that damage def over, unless you want to ferret out why it's working in your case first?

grayman

grayman

10.05.2013 03:23

administrator   ~0005393

Crap and double crap!

I had my 'base' directory turned on because I was testing something in 1.08 earlier and forgot to turn it off when using 2.0.

My bad.

With it off, I don't drown, and I get the STANDALONE message that damage_noair doesn't exist.

Yes, we need a 2.0 damage_noair.
Springheel

Springheel

10.05.2013 19:28

administrator   ~0005400

That and the damageDef 'damage_painTrigger' need to be added.

Issue History

Date Modified Username Field Change
09.05.2013 13:49 Springheel New Issue
10.05.2013 00:00 grayman Note Added: 0005379
10.05.2013 00:20 Springheel Note Added: 0005380
10.05.2013 00:41 grayman Note Added: 0005381
10.05.2013 01:34 Springheel Note Added: 0005386
10.05.2013 01:38 Springheel Note Added: 0005387
10.05.2013 01:38 Springheel Note Edited: 0005387 View Revisions
10.05.2013 01:38 Springheel Note Edited: 0005387 View Revisions
10.05.2013 01:46 Springheel Note Edited: 0005387 View Revisions
10.05.2013 03:23 grayman Note Added: 0005393
10.05.2013 19:28 Springheel Note Added: 0005400
10.05.2013 21:27 Springheel Status new => resolved
10.05.2013 21:27 Springheel Fixed in Version => TDM 2.00
10.05.2013 21:27 Springheel Resolution open => fixed
10.05.2013 21:27 Springheel Assigned To => Springheel