View Issue Details

IDProjectCategoryView StatusLast Update
0003431The Dark ModAIpublic21.12.2018 19:30
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003431: AI think they see you when coming out of blind state.
DescriptionThis has been around for awhile. When AI come out of their blind state after being flashbombed, they seem to always play their "spot player" bark, even if they can't see you.

This winds up sounding like this:

"I can't see!"
5 seconds later,
"AHa, there you are!" (player is around a corner out of sight)
half a second later,
"Huh, where'd he go?" (lost player bark)

They should not play their spot player bark when they can't actually see the player--they should skip right to their lost player bark.

TagsNo tags attached.

Relationships

has duplicate 0003167 closedgrayman Vocal barks back up when AI flashbombed 

Activities

grayman

grayman

04.06.2013 20:24

administrator   ~0005527

Most times I slipped around behind him after the flashbomb, and when he regained his sight, he cried, "There you are!" and turned toward me. I believe he's using the few seconds of "blind chasing" to reacquire me.

I was able to get him to exhibit the problem when I ran around a corner and it looks like his "blind chasing" didn't reacquire me.

So he must be barking that before he knows he's really reacquired me.
grayman

grayman

05.06.2013 16:38

administrator   ~0005528

Straighten out what happens when an AI is blinded while in combat. The problem was that the blind state was run, then the combat state was restarted, but forced to run initialization again, which caused the “I see you” bark and screwed things up in general.

Now the combat state is ended gracefully.

Also fixed a problem with an AI not searching when he regains his sight.

Since the blind state lasts 4s more than the blind anim, added code to make the AI stare down for the remainder of the state after the anim finishes, as if he’s waiting to regain his sight. Looks better than staring straight ahead like a dummy.

Rev. 5804:

BlindedState.cpp
BlindedState.h
CombatState.cpp
CombatState.h
State.cpp
State.h

Issue History

Date Modified Username Field Change
26.05.2013 02:36 Springheel New Issue
28.05.2013 15:44 Springheel Description Updated View Revisions
04.06.2013 20:21 grayman Assigned To => grayman
04.06.2013 20:21 grayman Status new => assigned
04.06.2013 20:24 grayman Note Added: 0005527
04.06.2013 20:24 grayman Status assigned => confirmed
05.06.2013 16:38 grayman Note Added: 0005528
05.06.2013 16:38 grayman Status confirmed => resolved
05.06.2013 16:38 grayman Resolution open => fixed
05.06.2013 16:38 grayman Fixed in Version => TDM 2.00
05.06.2013 16:38 grayman Target Version => TDM 2.00
21.12.2018 19:30 nbohr1more Relationship added has duplicate 0003167