View Issue Details

IDProjectCategoryView StatusLast Update
0003433The Dark ModAIpublic07.07.2013 14:25
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00 
Summary0003433: AI playing idle barks in combat mode
DescriptionI was trying to test mage fireballs. I shot a mage in the leg and then noclipped up into the air. He stood in combat pose looking at me, and gave at least two idle barks.

Obviously AI shouldn't be making idle barks when they're not in an idle state.
TagsNo tags attached.

Activities

Springheel

Springheel

30.05.2013 01:06

administrator   ~0005501

Ok, this was an unusual situation, since the mages weren't able to throw missiles and had no other way to reach me. Still shouldn't be playing idle barks though...if anything they should player the player out of reach barks.
grayman

grayman

02.06.2013 03:31

administrator   ~0005507

I tested this with rev 13490.

I also have "fire_range" set to zero for the regular mage, so he throws fireballs when I'm unreachable.

I saw no problems. When I was unreachable, he threw fireballs. When he couldn't see me, he lit up green and searched around. When he spotted me again, he would run to me if I was near the ground, or start throwing fireballs again if I wasn't.

I never heard any idle barks. I heard out of reach barks and agitated searching barks, as I would expect.

So I can't reproduce this problem with the latest rev and "fire_range" set to 0, which is what I think it should be for this character.
Springheel

Springheel

07.07.2013 14:24

administrator   ~0005653

I haven't seen any problems lately.

Issue History

Date Modified Username Field Change
30.05.2013 00:28 Springheel New Issue
30.05.2013 01:06 Springheel Note Added: 0005501
02.06.2013 03:31 grayman Note Added: 0005507
02.06.2013 03:33 grayman Assigned To => grayman
02.06.2013 03:33 grayman Status new => feedback
07.07.2013 14:24 Springheel Note Added: 0005653
07.07.2013 14:24 Springheel Status feedback => assigned
07.07.2013 14:25 Springheel Status assigned => resolved
07.07.2013 14:25 Springheel Resolution open => fixed