View Issue Details

IDProjectCategoryView StatusLast Update
0003449The Dark ModAIpublic11.06.2013 01:54
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003449: Alert index check problem in conversations
DescriptionAn AI can only enter a conversation if his alert state is Idle or Observant.

An AI must quit a conversation when his alert state is higher than Idle.

This inconsistency allows a conversation to be set up with an AI at alert state Observant, then killed a few moments later because the alert state is too high.

Given that AI in 2.00 are a bit more sensitive to alerts, the alert state for participating in a conversation should be set to Suspicious or less.
TagsNo tags attached.

Activities

grayman

grayman

11.06.2013 01:54

administrator   ~0005553

AI are allowed to be in conversations if their alert index is less than Searching.

Rev. 5811:

Conversation.cpp
ConversationState.cpp

Tested with Deceptive Shadows, using the conversation between the two Builder guards.

Issue History

Date Modified Username Field Change
11.06.2013 01:48 grayman New Issue
11.06.2013 01:48 grayman Status new => assigned
11.06.2013 01:48 grayman Assigned To => grayman
11.06.2013 01:54 grayman Note Added: 0005553
11.06.2013 01:54 grayman Status assigned => resolved
11.06.2013 01:54 grayman Resolution open => fixed
11.06.2013 01:54 grayman Fixed in Version => TDM 2.00