View Issue Details

IDProjectCategoryView StatusLast Update
0003572The Dark ModAIpublic05.10.2017 21:52
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.01 
Target VersionTDM 2.03Fixed in VersionTDM 2.03 
Summary0003572: Speed up AI door handling when running
DescriptionRight now, it's easy to gain ground on pursuing AI if you close a door in their face. It takes them several seconds to get through, giving the player plenty of time (too much) to escape.

Some suggestions:

1. Speed up animation, or at least the one with a weapon
2. Remove need for animation entirely when running
3. AI do not close door while in pursuit (might already be implemented)
TagsNo tags attached.

Relationships

has duplicate 0002932 closedgrayman Running AI or AI chasing an enemy should open doors more quickly. 
child of 0003755 resolvedgrayman Running AI getting caught up on doors 

Activities

grayman

grayman

18.10.2013 15:10

administrator   ~0006208

Last edited: 18.10.2013 15:10

View 2 revisions

For # 3, a running AI will not close a door behind him, even if he opened it.

Springheel

Springheel

19.10.2013 20:56

administrator   ~0006212

Good to know. For 2.01, I think I'll just look at speeding up the generic door open animation a bit.
Springheel

Springheel

23.11.2013 16:38

administrator   ~0006267

Last edited: 26.11.2013 14:31

View 2 revisions

I've added the following lines to humanoid_newskel.def. Will have to test how this looks and whether it creates any problems.


 "anim_rate_use_righthand" "1.5" // speed up door opening slightly
        "anim_rate_use_lefthand" "1.5" // speed up door opening slightly
        "anim_rate_sit_up" "1.3"

grayman

grayman

26.11.2013 18:21

administrator   ~0006273

There's a delay in the code to wait for the door to open.

I'll have to make that match the new animation.

The only condition is that he's running?
Springheel

Springheel

26.11.2013 18:25

administrator   ~0006274

Oh, didn't realize that. I was thinking this would be a quick way of trimming a second or two off the procedure, but if it requires an additional adjustment to the code, maybe we'd better wait and look at more robust solutions for 2.02.
grayman

grayman

26.11.2013 19:07

administrator   ~0006275

Actually, there are several things happening.

1 - animation

2 - wait for animation to reach point where hand is near door (estimated time is 1.1s)

3 - door opens at a certain rate

4 - AI moves through opening when he fits (though there might be more timing control than this going on)

I agree that this should move to 2.02. It's going to need testing with different types of doors, too.
grayman

grayman

15.07.2014 02:25

administrator   ~0006722

I've included the higher anim rates for using the hand.

I've adjusted the door-opening delays accordingly, and I like the higher rates better than the old rates.

They're still not fast enough for quick door handling, so I'll have to look at ways to get running AI through a closed door faster.

Since I use the electric relight anims for door controllers, I also sped them up 1.5, and will need to test those to make sure they still look okay. The anims notify the code when it's time to do the relight, so I don't need to adjust any timing in the relight code to compensate for the faster rates.

I need to test weapon and torch carrying AI, to see if I need separate higher anim rate defs for those replacement anims, or whether the faster rate is inherited automatically.
grayman

grayman

17.07.2014 18:59

administrator   ~0006727

The fixes submitted for issue 0003755 fix these problems.

Issue History

Date Modified Username Field Change
13.10.2013 16:18 Springheel New Issue
18.10.2013 15:10 grayman Note Added: 0006208
18.10.2013 15:10 grayman Note Edited: 0006208 View Revisions
19.10.2013 20:56 Springheel Note Added: 0006212
19.10.2013 20:56 Springheel Assigned To => Springheel
19.10.2013 20:56 Springheel Status new => assigned
23.11.2013 16:38 Springheel Note Added: 0006267
26.11.2013 14:31 Springheel Note Edited: 0006267 View Revisions
26.11.2013 14:31 Springheel Status assigned => feedback
26.11.2013 18:21 grayman Note Added: 0006273
26.11.2013 18:25 Springheel Note Added: 0006274
26.11.2013 18:25 Springheel Status feedback => assigned
26.11.2013 19:07 grayman Note Added: 0006275
28.11.2013 14:50 Springheel Target Version TDM 2.01 => TDM 2.02
23.03.2014 22:43 Springheel Target Version TDM 2.02 =>
18.06.2014 19:34 Springheel Assigned To Springheel =>
18.06.2014 19:35 Springheel Relationship added child of 0003755
08.07.2014 14:17 grayman Assigned To => grayman
15.07.2014 02:25 grayman Note Added: 0006722
15.07.2014 02:26 grayman Product Version => TDM 2.01
15.07.2014 02:26 grayman Target Version => TDM 2.03
17.07.2014 18:59 grayman Note Added: 0006727
17.07.2014 18:59 grayman Status assigned => resolved
17.07.2014 18:59 grayman Resolution open => fixed
17.07.2014 18:59 grayman Fixed in Version => TDM 2.03
05.10.2017 21:52 nbohr1more Relationship added related to 0002932
05.10.2017 21:52 nbohr1more Relationship deleted related to 0002932
05.10.2017 21:52 nbohr1more Relationship added has duplicate 0002932