View Issue Details

IDProjectCategoryView StatusLast Update
0004114DarkRadiantGeneralpublic07.01.2017 15:58
Reportergrayman Assigned To 
PrioritynormalSeveritynormalReproducibilityalways
Status confirmedResolutionreopened 
Product Version2.0.2 
Summary0004114: Incomplete update of camera view after saving
DescriptionAfter saving the map, if I right-click and hold in the camera view, and move the mouse around, the camera view is supposed to change.

What happens is that a small rectangle in the lower-right corner changes (correctly, I assume) but the rest of the camera view remains the same.

The condition clears if I right-click in one of the orthogonal views. Returning to the camera view and right-clicking and dragging now works correctly (the scene changes).
TagsNo tags attached.

Activities

grayman

grayman

08.03.2015 03:03

administrator   ~0007454

This also happens after an automatic snapshot.

This is a bit more disconcerting, because you can be in the middle of moving the camera view around, the snapshot occurs, and then you can't move the camera view anymore.
greebo

greebo

01.01.2017 18:13

administrator   ~0008687

Is this still happening?
grayman

grayman

03.01.2017 16:33

administrator   ~0008700

No.
greebo

greebo

03.01.2017 18:56

administrator   ~0008701

Well then, thanks for the update!
grayman

grayman

03.01.2017 21:50

administrator  

Untitled-1.jpg (221,015 bytes)   
Untitled-1.jpg (221,015 bytes)   
grayman

grayman

03.01.2017 21:51

administrator  

Untitled-2.jpg (295,075 bytes)
grayman

grayman

03.01.2017 21:52

administrator  

Untitled-3.jpg (217,968 bytes)   
Untitled-3.jpg (217,968 bytes)   
grayman

grayman

03.01.2017 21:54

administrator   ~0008702

Oops.

Another form of the problem just occurred.

I ^L-ed up the Layers menu and it laid itself across the camera window.

I selected a layer to show, and X-ed out of the window.

When I put the cursor in the camera window and held down the right-mouse button and swiveled left, only the part of the camera window that had been under the layers window moved; the rest of the window stayed put.

3 pics attached:

Untitled-1 is the camera window before showing the layers windows.

Untitled-2 shows the layers window laid on top of the camera window.

Untitled-3 shows what the camera window looks like after dismissing the layers window and swiveling left in the window.

The red lines show where the layers window was displayed.
greebo

greebo

04.01.2017 04:57

administrator   ~0008703

Interesting. Is this reproducible on your system? I tried to repro but it didn't occur on my end. Can it be reproduced on another system of yours, perhaps?
grayman

grayman

04.01.2017 14:09

administrator   ~0008704

Yes, it's reproducible.

I don't have a second system to try it on.

One more data point: If I bring up the layers window over the camera view, then hit its X-box to clear it, there are two behaviors when I right-click in the camera view:

1 - If I do it outside the area where the layers window was displayed, the camera moves correctly.

2 - If I do it inside the area, only the part of the camera view that's inside where the layers window was moves correctly. The part of the camera view that's outside is frozen. This state is cleared if I right-click in an ortho view and come back to the camera view.

I'm running on Win7.
greebo

greebo

07.01.2017 15:58

administrator   ~0008709

Hm, maybe we can get other users to repro this, it definitely doesn't happen on my end.

Issue History

Date Modified Username Field Change
08.03.2015 01:53 grayman New Issue
08.03.2015 03:03 grayman Note Added: 0007454
01.01.2017 18:13 greebo Note Added: 0008687
01.01.2017 18:13 greebo Status new => feedback
03.01.2017 16:33 grayman Note Added: 0008700
03.01.2017 16:33 grayman Status feedback => new
03.01.2017 18:56 greebo Note Added: 0008701
03.01.2017 18:56 greebo Status new => closed
03.01.2017 18:56 greebo Resolution open => unable to reproduce
03.01.2017 21:50 grayman File Added: Untitled-1.jpg
03.01.2017 21:51 grayman File Added: Untitled-2.jpg
03.01.2017 21:52 grayman File Added: Untitled-3.jpg
03.01.2017 21:54 grayman Note Added: 0008702
03.01.2017 21:54 grayman Status closed => feedback
03.01.2017 21:54 grayman Resolution unable to reproduce => reopened
04.01.2017 04:57 greebo Note Added: 0008703
04.01.2017 14:09 grayman Note Added: 0008704
04.01.2017 14:09 grayman Status feedback => new
07.01.2017 15:58 greebo Note Added: 0008709
07.01.2017 15:58 greebo Status new => confirmed