View Issue Details

IDProjectCategoryView StatusLast Update
0004340The Dark ModCodingpublic16.09.2017 18:49
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.04 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004340: Unnecessary WARNING when saving a game
DescriptionWhen saving a game, you can see several of these warnings on the console:

"WARNING: idSaveGame::WriteObject - WriteObject FindIndex failed"
Additional InformationI think what's happening is that the code is asked to save an object that's being pointed to, but the pointer is NULL because the object is undefined.

When asked to find a NULL object, the code spits out this warning.

Since NULL objects are okay, the WARNING should only be given when a non-null object can't be found. That's a real problem.
TagsNo tags attached.

Activities

grayman

grayman

16.09.2017 18:49

administrator   ~0009265

Opted to simply comment out the warning. As is, it's a useless warning.

Issue History

Date Modified Username Field Change
07.06.2016 18:52 grayman New Issue
21.10.2016 15:30 grayman Target Version TDM 2.05 => TDM 2.06
16.09.2017 18:49 grayman Note Added: 0009265
16.09.2017 18:49 grayman Assigned To => grayman
16.09.2017 18:49 grayman Status new => resolved
16.09.2017 18:49 grayman Resolution open => fixed
16.09.2017 18:49 grayman Fixed in Version => TDM 2.06