View Issue Details

IDProjectCategoryView StatusLast Update
0004560The Dark ModModelspublic10.08.2017 13:54
Reportergrayman Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.05 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004560: Chair doesn't cast a shadow
Descriptionmodels/darkmod/furniture/seating/leather_chair_001.lwo doesn't cast a shadow
TagsNo tags attached.

Activities

Springheel

Springheel

23.07.2017 00:54

administrator   ~0009028

Models aren't required to have a shadowmesh...what makes this a bug?
grayman

grayman

23.07.2017 01:08

administrator   ~0009029

Shine a light on it and it casts no shadow.

Did I get the terminology wrong?
Springheel

Springheel

23.07.2017 15:46

administrator   ~0009032

Ok, that makes more sense. That can be fixed by changing the texture to cast shadows.
grayman

grayman

23.07.2017 17:26

administrator   ~0009033

updated summary
Springheel

Springheel

09.08.2017 21:05

administrator   ~0009070

I checked the material, and it is set to noselfshadow.

Was it sitting on a material that was also set to noselfshadow? It should be casting shadows otherwise.
grayman

grayman

10.08.2017 01:03

administrator  

chair.jpg (256,804 bytes)   
chair.jpg (256,804 bytes)   
grayman

grayman

10.08.2017 01:03

administrator   ~0009072

Last edited: 10.08.2017 01:04

View 2 revisions

I've attached a picture of the chair sitting beneath a wall light.

Note that there is no shadow beneath the chair ( A ).

Note the shadows cast by the same light at ( B ) and ( C ).

grayman

grayman

10.08.2017 01:03

administrator   ~0009073

The chair is not marked "noshadows".
Springheel

Springheel

10.08.2017 13:14

administrator   ~0009074

I put the chair in a map and it cast a shadow as expected. I can't explain what is happening in that screenshot.
grayman

grayman

10.08.2017 13:44

administrator  

chairSH.jpg (215,527 bytes)   
chairSH.jpg (215,527 bytes)   
grayman

grayman

10.08.2017 13:45

administrator   ~0009075

Last edited: 10.08.2017 13:46

View 2 revisions

I attached another image, from bikerdude's work on Shadowhide's mission. Note that the small chair is throwing a shadow from the fireplace, but the problematic chair throws no shadow.

Could you post a screenshot showing the chair casting a shadow?

grayman

grayman

10.08.2017 13:51

administrator   ~0009076

Last edited: 10.08.2017 13:51

View 2 revisions

My image posted above is from w5_deceit, which is meant to play on 2.05. When I try it with SVN, the shadow appears.

So something changed after 2.05 was released. Either the chair or the light, I guess.

Since it works in SVN, I'll close this problem.

Issue History

Date Modified Username Field Change
10.07.2017 01:56 grayman New Issue
23.07.2017 00:54 Springheel Note Added: 0009028
23.07.2017 01:08 grayman Note Added: 0009029
23.07.2017 15:46 Springheel Note Added: 0009032
23.07.2017 15:46 Springheel Assigned To => Springheel
23.07.2017 15:46 Springheel Status new => assigned
23.07.2017 17:26 grayman Note Added: 0009033
23.07.2017 17:26 grayman Summary Chair has no shadow mesh => Chair doesn't cast a shadow
23.07.2017 17:26 grayman Description Updated View Revisions
09.08.2017 21:05 Springheel Note Added: 0009070
10.08.2017 01:03 grayman File Added: chair.jpg
10.08.2017 01:03 grayman Note Added: 0009072
10.08.2017 01:03 grayman Note Added: 0009073
10.08.2017 01:04 grayman Note Edited: 0009072 View Revisions
10.08.2017 13:14 Springheel Note Added: 0009074
10.08.2017 13:44 grayman File Added: chairSH.jpg
10.08.2017 13:45 grayman Note Added: 0009075
10.08.2017 13:46 grayman Note Edited: 0009075 View Revisions
10.08.2017 13:51 grayman Note Added: 0009076
10.08.2017 13:51 grayman Note Edited: 0009076 View Revisions
10.08.2017 13:54 grayman Status assigned => resolved
10.08.2017 13:54 grayman Resolution open => fixed
10.08.2017 13:54 grayman Fixed in Version => TDM 2.06