View Issue Details

IDProjectCategoryView StatusLast Update
0004599The Dark ModAnimationpublic15.09.2017 02:55
Reportergrayman Assigned Toduzenko  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004599: Flashing of odd dark shapes while testing an animation in SVN
DescriptionI'm adding code/script support to allow AI to fall asleep on a chair.

These animations were committed 3 years ago, so they're in 2.05:

sit_2_sleep_on_chair
sit_sleep_idle
sleep_2_sit_on_chair

If I test these in 2.05, using the following console commands:

testModel atdm:ai_citywatch
testAnim sit_2_sleep_on_chair

The animation plays normally, w/o any signs of flashing shapes.

However, if I test them in SVN, using the same console commands, I get flashing images that last a frame or so, in the vicinity of the model.
Steps To ReproduceStart a small TDM mission (or a test mission of your making), pull down the console, and enter the two lines given above.

You should see the flashing images.
TagsNo tags attached.

Activities

grayman

grayman

08.08.2017 15:10

administrator   ~0009065

The flashing also occurs during my tests, where I'm not using the console testModel/testAnim approach, but have the AI walking to a chair, sitting down, and entering the sit_2_sleep_on_chair animation.

So the problem is not limited to the testModel/testAnim commands.
nbohr1more

nbohr1more

08.08.2017 15:19

developer   ~0009066

This is mostly likely due to Cabalistic's threading patch.

This happens whenever Lightgem operations are not processed.

Same thing happens for me when setting:

tdm_lg_split 1
or
tdm_lg_interleave > 1
or
tdm_lg_weak
or
"during cinematics"
nbohr1more

nbohr1more

13.09.2017 21:42

developer   ~0009216

A fix for lightgem rendering bugs was applied recently, is this still happening?
duzenko

duzenko

14.09.2017 09:38

developer  

Untitled.jpg (335,013 bytes)
duzenko

duzenko

14.09.2017 09:40

developer   ~0009231

Can't repeat with tdm_lg_interleave 1, tdm_lg_weak 0, tdm_lg_split 1.
Screenshot attached.
grayman

grayman

15.09.2017 02:55

administrator   ~0009243

Tested with source rev 7139 and the problem is gone. Thanks!

Issue History

Date Modified Username Field Change
08.08.2017 15:06 grayman New Issue
08.08.2017 15:10 grayman Note Added: 0009065
08.08.2017 15:19 nbohr1more Note Added: 0009066
13.09.2017 21:42 nbohr1more Assigned To => duzenko
13.09.2017 21:42 nbohr1more Status new => feedback
13.09.2017 21:42 nbohr1more Note Added: 0009216
14.09.2017 09:38 duzenko File Added: Untitled.jpg
14.09.2017 09:40 duzenko Note Added: 0009231
15.09.2017 02:55 grayman Note Added: 0009243
15.09.2017 02:55 grayman Status feedback => assigned
15.09.2017 02:55 grayman Status assigned => resolved
15.09.2017 02:55 grayman Resolution open => fixed
15.09.2017 02:55 grayman Fixed in Version => TDM 2.06