View Issue Details

IDProjectCategoryView StatusLast Update
0004655The Dark ModGUIpublic14.11.2017 09:28
ReporterSpooks Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004655: Default Briefing GUI Doesn't Have Scroll Arrows
DescriptionTitle. Cannot scroll with the mouse wheel or the bracket keys either.
TagsNo tags attached.

Activities

grayman

grayman

12.11.2017 02:14

administrator   ~0009580

Mother Rose exhibits this behavior.
stgatilov

stgatilov

13.11.2017 09:25

administrator   ~0009593

Currently I cannot understand where the arrows are enabled.
mainmenu_briefing.gui has scrollDown and scrollUp subwindows, which must be the arrows.
It seems that their images are found properly.
Their visibility is controlled by gui::ScrollDownVisible and gui::ScrollUpVisible variables.
The only place where this variable is changed is CMissionData::UpdateGUIState.
The same variable also controls arrows in other places, e.g. in objectives list.
stgatilov

stgatilov

14.11.2017 09:27

administrator   ~0009611

Fixed in SVN rev 7286.

The problem was caused by changes:
  Revision: 7182
  Author: nbohr1more
  Date: 30 сентября 2017 г. 1:38:17
  nbohr1more: merge Durandall's scrolling mission list
I restored setting gui vars ScrollDownVisible and ScrollUpVisible in ModMenu.

Issue History

Date Modified Username Field Change
11.11.2017 12:56 Spooks New Issue
12.11.2017 02:14 grayman Note Added: 0009580
12.11.2017 02:14 grayman Target Version => TDM 2.06
13.11.2017 09:25 stgatilov Note Added: 0009593
14.11.2017 09:27 stgatilov Note Added: 0009611
14.11.2017 09:27 stgatilov Assigned To => stgatilov
14.11.2017 09:27 stgatilov Status new => assigned
14.11.2017 09:28 stgatilov Status assigned => resolved
14.11.2017 09:28 stgatilov Fixed in Version => TDM 2.06
14.11.2017 09:28 stgatilov Resolution open => fixed