View Issue Details

IDProjectCategoryView StatusLast Update
0004659The Dark ModDef / Setuppublic21.05.2018 17:12
ReporterSpringheel Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004659: r_showportals does not appear to be working
DescriptionTurning this on does not display anything at the moment.
TagsNo tags attached.

Activities

Springheel

Springheel

11.11.2017 13:37

administrator   ~0009568

I'm getting inconsistent results. When I tried it yesterday it didn't work, but trying it again today it worked correctly.
stgatilov

stgatilov

11.11.2017 16:06

administrator   ~0009572

I can definitely reproduce it.
Other debugging cvars work properly (e.g. r_showTrace).
stgatilov

stgatilov

13.11.2017 07:55

administrator   ~0009592

Duzenko, I have assigned it to you because you did most of the changes in renderer, so perhaps you are the most suitable person to check why portals are not rendered.

There are many debug visualizations which are broken now (even without SMP). But the one about portals is used regularly by mappers, isn't it?
duzenko

duzenko

13.11.2017 10:33

developer  

Untitled.jpg (346,596 bytes)
duzenko

duzenko

13.11.2017 10:34

developer   ~0009594

Need steps to reproduce. Attached picture shows how r_showportals 1 works for me in Closemouthed Shadows.
http://bugs.thedarkmod.com/file_download.php?file_id=519&type=bug
grayman

grayman

14.11.2017 01:57

administrator   ~0009608

What I've noticed is that in more confined spaces, like inside a house, the portals are shown, but in more open spaces, like a street or courtyard outside a house, portals are not shown.

I can be standing in the street, with no portals painted, and open the door to the house. Step inside and shut the door, and the inside portals appear. It's the reverse when I go from inside to outside.
grayman

grayman

14.11.2017 02:40

administrator   ~0009610

I tried to make a test map showing what I'd seen, but I couldn't get the portal painting to fail.

All I can offer is Mother Rose. It's a small map, with an inside/outside design. There are large visportals outside the Doctor's house.

If you start the map and turn on r_showportals, nothing shows up. But if you enter the Dr's house using noclip (it's the house on the right when you walk through the cemetery gate), the inside portals appear. Go back outside, and the portals disappear.

Use notarget to keep the patrolling guard from interfering.

If you pick the lock on the front door, go inside, shut the door, then open it again, you'll see the outside portals flash on, then off.
duzenko

duzenko

24.11.2017 13:23

developer   ~0009689

Last edited: 24.11.2017 13:26

View 2 revisions

Narrowed it down to portal sky. Might be related to recent change of portal sky = subview.
Workaround: g_enablePortalSky 0

duzenko

duzenko

24.11.2017 14:05

developer   ~0009690

I think all subviews are screwing showportals. The problem is that the tool is relying on portal's last view being also the front renderer last view.
I will see if I can change from tr.viewCount to current view in backend.
duzenko

duzenko

24.11.2017 14:39

developer   ~0009691

Revision: 7307
----
Modified : /trunk/renderer/RenderWorld_portals.cpp
duzenko

duzenko

24.11.2017 14:41

developer   ~0009692

Note: this tool is NOT generally compatible with com_smp because it feeds on lastView No.
grayman

grayman

24.11.2017 16:12

administrator   ~0009693

Verified working again in Mother Rose.

user81

27.03.2018 09:55

  ~0010161

This appears to be semi-buggy still, if I am in the room or visleaf that I want to check the Visportals in they aren't being shown. However if I move some distance away and then look back at that location I can seen them, but even then they randomly appear and disappear.
grayman

grayman

27.03.2018 13:02

administrator   ~0010162

Last edited: 27.03.2018 13:03

View 2 revisions

@Biker: try this workaround.

In your map, instead of using a single ambient_world to cover the entire map, including the skybox, do this instead:

1 - duplicate ambient_world (ambient_world1) and stick ambient_world1 in your skybox. Size it to cover the skybox only.

2 - Move ambient_world into the map and size it so it covers the map, but doesn't cover the skybox.

See if that helps.

nbohr1more

nbohr1more

21.05.2018 17:11

developer   ~0010465

Most of the fixes for this are in place in 2.06.

SMP is auto-disabled when using this cvar per the no_smp flag in Session.cpp.

    //nbohr1more: disable SMP for debug render tools
    if (r_showSurfaceInfo.GetBool() ||
    r_showSilhouette.GetBool() ||
    r_showViewEntitys.GetBool() ||
    r_showEdges.GetBool() ||
    r_showPortals.GetBool() ||
    r_showViewEntitys.GetBool() ||
    r_showShadowCount.GetBool() ||
    r_showLightCount.GetBool() ||
    r_showDepth.GetBool() ||
    r_showTris.GetInteger() > 0 ||
    r_showLights.GetInteger() > 0 ) {
    no_smp = true;
    } else {
    no_smp = false;
}

Please open a tracker for 2.07 to cover the remaining issues.

Issue History

Date Modified Username Field Change
11.11.2017 13:21 Springheel New Issue
11.11.2017 13:37 Springheel Note Added: 0009568
11.11.2017 16:06 stgatilov Note Added: 0009572
13.11.2017 07:53 stgatilov Assigned To => duzenko
13.11.2017 07:53 stgatilov Status new => assigned
13.11.2017 07:55 stgatilov Note Added: 0009592
13.11.2017 10:33 duzenko File Added: Untitled.jpg
13.11.2017 10:34 duzenko Note Added: 0009594
14.11.2017 01:57 grayman Note Added: 0009608
14.11.2017 02:40 grayman Note Added: 0009610
24.11.2017 13:23 duzenko Note Added: 0009689
24.11.2017 13:26 duzenko Note Edited: 0009689 View Revisions
24.11.2017 14:05 duzenko Note Added: 0009690
24.11.2017 14:39 duzenko Note Added: 0009691
24.11.2017 14:39 duzenko Status assigned => resolved
24.11.2017 14:39 duzenko Fixed in Version => TDM 2.06
24.11.2017 14:39 duzenko Resolution open => fixed
24.11.2017 14:41 duzenko Note Added: 0009692
24.11.2017 16:12 grayman Note Added: 0009693
27.03.2018 09:55 user81 Note Added: 0010161
27.03.2018 09:55 user81 Status resolved => feedback
27.03.2018 09:55 user81 Resolution fixed => reopened
27.03.2018 13:02 grayman Note Added: 0010162
27.03.2018 13:03 grayman Note Edited: 0010162 View Revisions
21.05.2018 17:11 nbohr1more Note Added: 0010465
21.05.2018 17:12 nbohr1more Status feedback => resolved
21.05.2018 17:12 nbohr1more Resolution reopened => fixed