View Issue Details

IDProjectCategoryView StatusLast Update
0004673The Dark ModGraphicspublic29.04.2018 21:06
ReporterSpooks Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
OSWindowsOS Version7 
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004673: Cubemap stages in materials are broken.
DescriptionCubemap stages in 2.06 do not interact with normal maps and appear tilted, which is not the case in 2.05. Nothing with the mtr syntax has changed, therefore the problem likely lies in the vertex/fragment program.



An example, default texture with a cubemap stage is textures/glass/dull_opaque01. It is used on Springheel's window models.
Additional InformationEither environment.vfp, bumpyEnvironment.vfp or interaction.vfp could be the program that is responsible for processing cubemap stages. It has been forever since I've dug in those files, however, so even those might be false leads.

See a screenshot of the problem and another, example material definition with a cubemap stage in this post: http://forums.thedarkmod.com/topic/19162-beta-testing-206/?p=414647
TagsNo tags attached.

Activities

VanishedOne

VanishedOne

16.11.2017 20:53

developer   ~0009631

I think stgatilov was looking into this. He asked me about cubemaps via PM and I sent him a test map.
duzenko

duzenko

18.11.2017 15:53

developer   ~0009635

Can you attach the test map here as well?
duzenko

duzenko

19.11.2017 08:50

developer   ~0009636

Last edited: 19.11.2017 08:53

View 4 revisions

I can't see the problem.
You mean the "lamp" cubic light?
I can see it interacting with the bricks2 material using the normal map.
Or is it about the ambient light? But then what do you mean by "cubemap stage"? The material itself does not include any cubemaps that I can see.
Screenshot attached.

duzenko

duzenko

19.11.2017 08:51

developer  

Untitled.jpg (444,899 bytes)
Spooks

Spooks

19.11.2017 11:01

reporter   ~0009637

I have attached a new test map with the bare minimum so the problem can be spotted more easily. There is only an ambient_world light for visibility, six walls and a player spawn.

The cubemap is defined inside the shader's material definition. The attached map uses textures/glass/dull_opaque01, inside tdm_glass.mtr for testing. The code block in that definition looks like this:

    {
        maskcolor
        map makealpha(textures/glass/glass1)
    }
    // now use the alpha mask to add some fake reflections
    {
        blend gl_dst_alpha, gl_one
        maskalpha
        cubeMap env/gen3
        
                texgen reflect
    }

Most other shaders have similar syntax WRT their cubemap stages.

Running the map in 2.05 and 2.06 should show that the cubemap stage doesn't properly get affected by the shader's normal map like it used to.
Spooks

Spooks

19.11.2017 11:02

reporter  

dull_opaque01.map (4,073 bytes)
duzenko

duzenko

19.11.2017 18:49

developer   ~0009639

Last edited: 19.11.2017 18:50

View 3 revisions

Svn rev 7292: passing tex coords to bumpy environment shader
Please test if it makes any difference to you

Spooks

Spooks

19.11.2017 23:53

reporter   ~0009640

As I don't have SVN access, I'll either wait until the next beta package to test this fix, or you could ask nbhor1more to verify this. I will report here later regardless.
nbohr1more

nbohr1more

20.11.2017 02:50

developer   ~0009641

The test map now looks identical to 2.05.
I'll leave this in feedback status until the next 2.06 beta package is up.
Spooks

Spooks

25.11.2017 13:35

reporter   ~0009699

I can confirm that now with the latest package. Someone like VanishedOne might want to chime in since he's also noticed the bug, but it seems fixed to me.

Issue History

Date Modified Username Field Change
16.11.2017 20:24 Spooks New Issue
16.11.2017 20:53 VanishedOne Note Added: 0009631
18.11.2017 15:53 duzenko Note Added: 0009635
19.11.2017 08:50 duzenko Note Added: 0009636
19.11.2017 08:51 duzenko File Added: Untitled.jpg
19.11.2017 08:52 duzenko Note Edited: 0009636 View Revisions
19.11.2017 08:52 duzenko Note Edited: 0009636 View Revisions
19.11.2017 08:53 duzenko Note Edited: 0009636 View Revisions
19.11.2017 08:53 duzenko Assigned To => duzenko
19.11.2017 08:53 duzenko Status new => assigned
19.11.2017 11:01 Spooks Note Added: 0009637
19.11.2017 11:02 Spooks File Added: dull_opaque01.map
19.11.2017 18:49 duzenko Note Added: 0009639
19.11.2017 18:49 duzenko Note Edited: 0009639 View Revisions
19.11.2017 18:50 duzenko Note Edited: 0009639 View Revisions
19.11.2017 23:53 Spooks Note Added: 0009640
20.11.2017 02:50 nbohr1more Note Added: 0009641
20.11.2017 02:50 nbohr1more Status assigned => feedback
20.11.2017 02:50 nbohr1more Fixed in Version => TDM 2.06
20.11.2017 02:50 nbohr1more Target Version => TDM 2.06
25.11.2017 13:35 Spooks Note Added: 0009699
25.11.2017 13:35 Spooks Status feedback => assigned
02.12.2017 12:42 duzenko Assigned To duzenko => nbohr1more
06.12.2017 14:38 nbohr1more Status assigned => resolved
06.12.2017 14:38 nbohr1more Resolution open => fixed
29.04.2018 21:06 nbohr1more Assigned To nbohr1more => duzenko