View Issue Details

IDProjectCategoryView StatusLast Update
0004837The Dark ModGraphicspublic16.06.2018 22:48
Reporterduzenko Assigned Tocabalistic  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004837: Fog lights started flickering in Inn Business somewhere between 7406 and 7442
DescriptionAll rev's between 7406 and 7442 won't load the Inn Business map (freeze on load).
Fog lights worked before 7406, not working after 7442.
TagsNo tags attached.

Activities

cabalistic

cabalistic

16.06.2018 12:29

developer   ~0010530

The map loads fine for me un current trunk, so that part of the problem should be fixed?

Where do I need to go in the map to see the fog lights and their issues? A quick noclip fly around the initial area shows no visual differences to 2.06.
nbohr1more

nbohr1more

16.06.2018 13:12

developer   ~0010532

Last edited: 16.06.2018 13:12

View 2 revisions

From Discussion here:

http://forums.thedarkmod.com/topic/19487-dynamic-internal-images-vs-fbo/#entry423132

To address the flickering, I replaced RB_T_RenderTriangleSurface( surf ) with
RB_DrawElementsImmediate (tri).

This seems to resolve almost all issues but... "Thief's Den 3: Heart of Lone Salvation" AI and particle based trees have either flicker fog or no fog depending on your movement or theirs.

Duzenko has also raised the concern that RB_DrawElementsImmediate is far more costly than RB_T_RenderTriangleSurface or RB_DrawElementsWithCounters.

duzenko

duzenko

16.06.2018 15:04

developer   ~0010534

@cabalistic, yes, it loads fine since rev 7442. I only mentioned that because I couldn't find the exact commit that broke the fog light because of the load issue.

To answer your other question: see svn rev 7471. If you replace RB_DrawElementsImmediate with RB_T_RenderTriangleSurface you will notice greyish flickering in the sky right after player spawn.
cabalistic

cabalistic

16.06.2018 22:48

developer   ~0010535

Fixed in rev. 7481.

Issue History

Date Modified Username Field Change
15.06.2018 11:20 duzenko New Issue
15.06.2018 11:20 duzenko Status new => assigned
15.06.2018 11:20 duzenko Assigned To => cabalistic
15.06.2018 11:21 duzenko Summary Fog lights broken somewhere between 7406 and 7442 => Fog lights started flickering in Inn Business somewhere between 7406 and 7442
16.06.2018 12:29 cabalistic Note Added: 0010530
16.06.2018 13:12 nbohr1more Note Added: 0010532
16.06.2018 13:12 nbohr1more Note Edited: 0010532 View Revisions
16.06.2018 15:04 duzenko Note Added: 0010534
16.06.2018 22:47 cabalistic Status assigned => resolved
16.06.2018 22:47 cabalistic Fixed in Version => TDM 2.07
16.06.2018 22:47 cabalistic Resolution open => fixed
16.06.2018 22:48 cabalistic Note Added: 0010535