View Issue Details

IDProjectCategoryView StatusLast Update
0004891The Dark ModGraphicspublic30.11.2018 21:18
Reportergrayman Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004891: Weird compass problem
DescriptionSee this thread:

http://forums.thedarkmod.com/topic/19673-weird-compass-in-svn/#entry428277
TagsNo tags attached.

Relationships

related to 0004569 resolvedduzenko GUI renderDef Lights do not work 

Activities

nbohr1more

nbohr1more

28.11.2018 22:12

developer   ~0010804

Last edited: 28.11.2018 22:12

View 2 revisions

I have seen this too.

I believe the problem lies in the fact that the compass is rendered in a
GUI where there is broken stub code for the lighting since the
changes described in 0004569.

In older engine builds, this simply broke the lighting but now all rendering is
predicated on having the correct FBO attributes and the broken stub code is not
generating the source data for the FBO's.

grayman

grayman

29.11.2018 02:03

administrator   ~0010805

Since this might have something to do with FBO, and I know nothing about that, I don't think it should be assigned to me.
grayman

grayman

29.11.2018 02:06

administrator   ~0010806

This still occurs playing "A New Job" with the latest SVN build as of today.
duzenko

duzenko

29.11.2018 17:38

developer   ~0010807

At revision: 7771
All HUD's need re-testing
grayman

grayman

30.11.2018 21:18

administrator   ~0010811

Verified fixed at rev. 7772.

Thank you.

Issue History

Date Modified Username Field Change
02.10.2018 11:15 grayman New Issue
02.10.2018 11:15 grayman Status new => assigned
02.10.2018 11:15 grayman Assigned To => grayman
28.11.2018 22:08 nbohr1more Relationship added related to 0004569
28.11.2018 22:12 nbohr1more Note Added: 0010804
28.11.2018 22:12 nbohr1more Note Edited: 0010804 View Revisions
29.11.2018 02:03 grayman Note Added: 0010805
29.11.2018 02:03 grayman Assigned To grayman =>
29.11.2018 02:04 grayman Status assigned => acknowledged
29.11.2018 02:06 grayman Note Added: 0010806
29.11.2018 02:43 nbohr1more Assigned To => duzenko
29.11.2018 17:38 duzenko Note Added: 0010807
29.11.2018 17:38 duzenko Status acknowledged => resolved
29.11.2018 17:38 duzenko Fixed in Version => TDM 2.07
29.11.2018 17:38 duzenko Resolution open => fixed
30.11.2018 21:18 grayman Note Added: 0010811