View Issue Details

IDProjectCategoryView StatusLast Update
0005091DarkRadiantGUIpublic08.11.2020 18:36
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityN/A
Status closedResolutionfixed 
Product Version2.6.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0005091: Add "Choose Skin" button when editing model spawnarg of an existing entity
DescriptionAt present, the model list that's brought up when changing the model spawnarg of an existing entity doesn't show the skins available.

(My workaround has been to bring up the model list from 'Create model' to check which skins are available for the newly changed model.)
TagsNo tags attached.

Activities

greebo

greebo

31.12.2019 04:20

administrator   ~0011992

That's working as designed, since the Entity Inspector is always editing just one single spawnarg at a time. So, when you select the "model" spawnarg, you're just looking for models - to change the skin of a model, you need to edit the "skin" spawnarg, which will provide you with a list of skins available for that model. If no "skin" spawnarg is present on the entity, you'll need to add it first.
Dragofer

Dragofer

01.01.2020 22:58

developer   ~0012007

That's a shame, for me models and skins go together like bread and butter. But if that button only modifies one spawnarg at a time then so be it.

Come to think of it, my actual procedure for getting a skin onto an existing model is always to give it a "skin" "1" spawnarg, then click on "Choose skin...". It's less cumbersome than creating a new model with the desired skin & transferring, but new mappers have to think of that technique first.

How about adding a "Choose skin..." button to the model spawnarg? That'd make things easier for new & veteran mappers.
greebo

greebo

04.01.2020 04:58

administrator   ~0012055

I have to check how far the current design is stretched when adding such a Choose Skin button to the "model" spawnarg editor.
Alternatively, would a "Set Model" and "Set Skin" option to the right-click context menu help, since these two are likely the most commonly used spawnargs on entities?
Dragofer

Dragofer

04.01.2020 23:29

developer   ~0012061

I like your suggestion. DR is missing a method to 'create' a skin spawnarg on a model (only indirectly by i.e. "skin" "1" or copy-pasting from another entity) and it's an essential spawnarg.

In my opinion a 'set model' option isn't really needed though, because most relevant entities already have a model spawnarg with 'Choose model'.
Dragofer

Dragofer

04.01.2020 23:45

developer   ~0012062

Ah, I just remembered that there's a right-click 'Add spawnarg' function that easily adds a skin spawnarg. I got out of the habit of using that many years ago because I knew most of the ones in there by heart. That makes the added benefit of the solutions discussed in these notes fairly slim in my view.

Well, my bug report was that 'Create model' lets you choose skins but 'Choose model' doesn't. Would be convenient if they both did, but you already responded to that in your first note.
greebo

greebo

05.01.2020 04:06

administrator   ~0012065

I had a brief look at the PropertyEditors, and it's perfectly feasible to add a "Choose skin" button to the model spawnarg editor. So I went ahead and implemented this:
model_plus_skin_button.png (14,902 bytes)   
model_plus_skin_button.png (14,902 bytes)   
greebo

greebo

05.01.2020 04:09

administrator   ~0012066

Resolved in 6f24b32612

Issue History

Date Modified Username Field Change
30.12.2019 09:30 Dragofer New Issue
31.12.2019 04:20 greebo Status new => acknowledged
31.12.2019 04:20 greebo Note Added: 0011992
01.01.2020 22:58 Dragofer Note Added: 0012007
04.01.2020 04:58 greebo Note Added: 0012055
04.01.2020 23:29 Dragofer Note Added: 0012061
04.01.2020 23:45 Dragofer Note Added: 0012062
05.01.2020 04:06 greebo File Added: model_plus_skin_button.png
05.01.2020 04:06 greebo Note Added: 0012065
05.01.2020 04:07 greebo Target Version => 2.7.0
05.01.2020 04:07 greebo Summary No skin selection when changing model of an existing entity => Add "Choose Skin" button when editing model spawnarg of an existing entity
05.01.2020 04:07 greebo Assigned To => greebo
05.01.2020 04:07 greebo Status acknowledged => confirmed
05.01.2020 04:09 greebo Status confirmed => assigned
05.01.2020 04:09 greebo Status assigned => resolved
05.01.2020 04:09 greebo Resolution open => fixed
05.01.2020 04:09 greebo Fixed in Version => 2.7.0
05.01.2020 04:09 greebo Note Added: 0012066
08.11.2020 18:36 greebo Status resolved => closed