View Issue Details

IDProjectCategoryView StatusLast Update
0005108DarkRadiantSaving and loadingpublic30.11.2020 04:09
ReporterDragofer Assigned Togreebo  
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
OSWindowsOS Version10 
Product Version2.6.0 
Target Version2.10.0Fixed in Version2.10.0 
Summary0005108: Allow DR to open .maps that are inside .pk4s
DescriptionI often want to look at other people's maps to see how they did something, or what's causing a bug while I'm betatesting.

However, I'm not aware of any way to open a .map in DR while it's still in its .pk4 archive, so I need to extract the archive or just the maps folder first.

I think it'd be a neat little feature if, after clicking on 'Open', I could double-click on the .pk4s to see & open the maps that are inside.
TagsNo tags attached.

Activities

greebo

greebo

06.01.2020 04:30

administrator   ~0012085

Tough one, because the file picker is used as delivered by Windows/Linux/macOS which don't support opening the PK4 files.
I already wanted to have such a feature myself, so unless I have some enlightening idea it's going to be a separate "Open Map from PK4" dialog.

I also wanted to have a "Repo Browser" feature some time in the past, where I can browse the file structure as the game is perceiving it, where one can see the folders and select files to see which PK4 or folder they are defined in.
Dragofer

Dragofer

06.01.2020 22:48

developer   ~0012098

'Open map from .pk4' would already be perfect. It's just a small thing, so it shouldn't become a complicated project just to get this.

A repro browser sounds interesting, but so far it's already helped to see where materials are defined.

Related Changesets

DarkRadiant: openmapsfrompk4 dbcb3ffd

2020-11-16 16:12:32

greebo

Details Diff
0005108: Refactor PrefabSelector, start extracting a base FileSystemView class and use that instead. Affected Issues
0005108
mod - libs/wxutil/Makefile.am Diff File
mod - libs/wxutil/TreeView.cpp Diff File
mod - libs/wxutil/TreeView.h Diff File
add - libs/wxutil/fsview/FileSystemView.cpp Diff File
add - libs/wxutil/fsview/FileSystemView.h Diff File
add - libs/wxutil/fsview/Populator.cpp Diff File
add - libs/wxutil/fsview/Populator.h Diff File
mod - radiant/ui/prefabselector/PrefabSelector.cpp Diff File
mod - radiant/ui/prefabselector/PrefabSelector.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 f47cb2c8

2020-11-16 16:46:25

greebo

Details Diff
0005108: Remove now unused PrefabPopulator. Add some default file icon handling code. Affected Issues
0005108
add - install/bitmaps/file.png Diff File
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/FileSystemView.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - radiant/Makefile.am Diff File
rm - radiant/ui/prefabselector/PrefabPopulator.cpp Diff File
rm - radiant/ui/prefabselector/PrefabPopulator.h Diff File
mod - radiant/ui/prefabselector/PrefabSelector.cpp Diff File
mod - radiant/ui/prefabselector/PrefabSelector.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 ab5307a6

2020-11-16 17:12:33

greebo

Details Diff
0005108: Make listed file extensions configurable Affected Issues
0005108
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/FileSystemView.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - radiant/ui/prefabselector/PrefabSelector.cpp Diff File

DarkRadiant: openmapsfrompk4 0d9be848

2020-11-16 19:16:11

greebo

Details Diff
0005108: Use the prefab icon, as before the refactoring Affected Issues
0005108
mod - radiant/ui/prefabselector/PrefabSelector.cpp Diff File

DarkRadiant: openmapsfrompk4 d1109394

2020-11-17 04:08:32

greebo

Details Diff
0005108: Add dialog and menu option to pick a file from the current project (incl. PK4s) Affected Issues
0005108
mod - install/menu.xml Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
add - radiant/ui/mapselector/MapSelector.cpp Diff File
add - radiant/ui/mapselector/MapSelector.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 c4388709

2020-11-17 05:54:13

greebo

Details Diff
0005108: Add file size to FileSystemView. Affected Issues
0005108
add - libs/os/filesize.h Diff File
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 4de5833b

2020-11-17 06:20:54

greebo

Details Diff
0005108: Add VirtualFileSystem::getArchiveExtensions() method, list PK4 files in MapSelector Affected Issues
0005108
mod - include/ifilesystem.h Diff File
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiantcore/vfs/Doom3FileSystem.cpp Diff File
mod - radiantcore/vfs/Doom3FileSystem.h Diff File

DarkRadiant: openmapsfrompk4 11cb2b13

2020-11-17 07:21:11

greebo

Details Diff
0005108: Add ability to register icons for file types Affected Issues
0005108
mod - include/ifiletypes.h Diff File
mod - radiantcore/filetypes/FileTypeRegistry.cpp Diff File
mod - radiantcore/filetypes/FileTypeRegistry.h Diff File

DarkRadiant: openmapsfrompk4 5b5f1d88

2020-11-17 07:21:33

greebo

Details Diff
0005108: Register icon for game pak files Affected Issues
0005108
add - install/bitmaps/package.png Diff File
mod - radiantcore/settings/GameManager.cpp Diff File

DarkRadiant: openmapsfrompk4 0dbd819c

2020-11-17 07:23:17

greebo

Details Diff
0005108: Use the registered icon in the file type registry to display icons Affected Issues
0005108
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File

DarkRadiant: openmapsfrompk4 ae431ff6

2020-11-17 07:40:09

greebo

Details Diff
0005108: OK button is not sensitive until a map file is selected Affected Issues
0005108
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.h Diff File

DarkRadiant: openmapsfrompk4 0aa6d018

2020-11-17 08:04:00

greebo

Details Diff
0005108: Add some tests covering the file type registry Affected Issues
0005108
add - test/FileTypes.cpp Diff File
mod - test/Makefile.am Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 dddbeb27

2020-11-17 08:30:28

greebo

Details Diff
0005108: Add second option to browse for a specific PK4 and list its contents (not implemented yet) Affected Issues
0005108
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.h Diff File

DarkRadiant: openmapsfrompk4 0932b02c

2020-11-17 12:11:52

greebo

Details Diff
0005108: Move Archive interface to iarchive.h to make it public. Add VirtualFileSystem::openArchiveInAbsolutePath method to load an independent PAK file for inspection. Affected Issues
0005108
mod - include/iarchive.h Diff File
mod - include/ifilesystem.h Diff File
rm - radiantcore/vfs/Archive.h Diff File
mod - radiantcore/vfs/DirectoryArchive.h Diff File
mod - radiantcore/vfs/Doom3FileSystem.cpp Diff File
mod - radiantcore/vfs/Doom3FileSystem.h Diff File
mod - radiantcore/vfs/GenericFileSystem.h Diff File
mod - radiantcore/vfs/ZipArchive.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 88e372be

2020-11-17 12:53:39

greebo

Details Diff
0005108: Unit test covering the new VFS method. Affected Issues
0005108
mod - test/VFS.cpp Diff File

DarkRadiant: openmapsfrompk4 a4ece374

2020-11-18 03:02:18

greebo

Details Diff
0005108: WIP commit Affected Issues
0005108
mod - libs/wxutil/fsview/FileSystemView.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File

DarkRadiant: openmapsfrompk4 19878636

2020-11-19 13:22:31

greebo

Details Diff
0005108: Move AssetsList and FileVisitor classes to libs/vfs/ to make it usable from other places Affected Issues
0005108
add - libs/vfs/AssetsList.h Diff File
add - libs/vfs/FileVisitor.h Diff File
mod - radiantcore/vfs/Doom3FileSystem.cpp Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 f183d3b7

2020-11-19 13:47:36

greebo

Details Diff
0005108: Expand FileSystem interface to search an arbitrary archive on disk
Move FileVisitor and AssetsList back to the private vfs sources for as long as we can get away with it.
Affected Issues
0005108
mod - include/ifilesystem.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - radiantcore/vfs/Doom3FileSystem.cpp Diff File
mod - radiantcore/vfs/Doom3FileSystem.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 933f954a

2020-11-19 14:21:15

greebo

Details Diff
0005108: Extend VFSTreePopulator interface to include the full path info when immediately populating the items we're adding. Affected Issues
0005108
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/VFSTreePopulator.cpp Diff File
mod - libs/wxutil/VFSTreePopulator.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - radiant/ui/einspector/SkinChooser.cpp Diff File
mod - radiant/uimanager/SoundChooser.cpp Diff File

DarkRadiant: openmapsfrompk4 b510768c

2020-11-19 15:51:08

greebo

Details Diff
0005108: Open listed PK4 files on double click Affected Issues
0005108
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.h Diff File

DarkRadiant: openmapsfrompk4 d58ed929

2020-11-19 16:44:08

greebo

Details Diff
0005108: Expand the maps/ folder after loading the tree Affected Issues
0005108
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/FileSystemView.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.h Diff File

DarkRadiant: openmapsfrompk4 0f615a18

2020-11-20 03:52:57

greebo

Details Diff
0005108: Extend the FileInfo structure passed out to clients by the ability to load more information about the file on demand.
Add IArchiveFileInfoProvider interface which is optionally passed to the FileInfo constructor.
Affected Issues
0005108
mod - include/iarchive.h Diff File
mod - include/ifilesystem.h Diff File
mod - plugins/sound/SoundManager.cpp Diff File
mod - radiantcore/eclass/Doom3EntityClass.cpp Diff File
mod - radiantcore/shaders/ShaderDefinition.h Diff File
mod - radiantcore/shaders/ShaderLibrary.cpp Diff File

DarkRadiant: openmapsfrompk4 96e15e3c

2020-11-20 03:56:56

greebo

Details Diff
0005108: Add a quick unit test covering VirtualFileSystem::forEachFileInArchive Affected Issues
0005108
mod - test/VFS.cpp Diff File

DarkRadiant: openmapsfrompk4 61482364

2020-11-20 04:54:31

greebo

Details Diff
0005108: Hook the IArchiveFileInfoProvider reference into the traversal routines.
The IArchive implementations now implement IArchiveFileInfoProvider too.
Affected Issues
0005108
mod - include/iarchive.h Diff File
mod - libs/os/file.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - radiantcore/vfs/DirectoryArchive.cpp Diff File
mod - radiantcore/vfs/DirectoryArchive.h Diff File
mod - radiantcore/vfs/FileVisitor.h Diff File
mod - radiantcore/vfs/GenericFileSystem.h Diff File
mod - radiantcore/vfs/ZipArchive.cpp Diff File
mod - radiantcore/vfs/ZipArchive.h Diff File

DarkRadiant: openmapsfrompk4 3df1215e

2020-11-20 05:03:44

greebo

Details Diff
0005108: Add unit tests asserting that we can get the file size of both physical files and those in a PK4. Affected Issues
0005108
mod - include/ifilesystem.h Diff File
mod - test/VFS.cpp Diff File

DarkRadiant: openmapsfrompk4 9f7fcc73

2020-11-20 05:48:30

greebo

Details Diff
0005108: Use the base path as root item of the FileSystem view Affected Issues
0005108
mod - libs/wxutil/VFSTreePopulator.cpp Diff File
mod - libs/wxutil/VFSTreePopulator.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - radiant/ui/mapselector/MapSelector.cpp Diff File

DarkRadiant: openmapsfrompk4 a12489e3

2020-11-20 08:32:03

greebo

Details Diff
0005108: Store more info in the file tree, use a nice root item for display Affected Issues
0005108
mod - include/ifilesystem.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File

DarkRadiant: openmapsfrompk4 5fd0dcb5

2020-11-20 09:57:35

greebo

Details Diff
0005108: Remove superfluous leading slash when traversing a directory in the file system. Add unit test covering that. Affected Issues
0005108
mod - radiantcore/vfs/Doom3FileSystem.cpp Diff File
mod - test/VFS.cpp Diff File

DarkRadiant: openmapsfrompk4 1492339a

2020-11-20 09:58:06

greebo

Details Diff
0005108: Fix PrefabSelector not displaying files in absolute folders due to missing trailing slash Affected Issues
0005108
mod - radiant/ui/prefabselector/PrefabSelector.cpp Diff File

DarkRadiant: openmapsfrompk4 07aa55ab

2020-11-20 09:58:54

greebo

Details Diff
0005108: Properly calculate the VFS path of tree items when traversing external PK4 files.
Don't repopulate the tree if the base path is not changing.
Affected Issues
0005108
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/FileSystemView.h Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.h Diff File

DarkRadiant: openmapsfrompk4 49b50330

2020-11-20 10:04:34

greebo

Details Diff
0005108: Use the mod name before any base path when browsing mod resources. Affected Issues
0005108
mod - libs/wxutil/fsview/Populator.cpp Diff File

DarkRadiant: openmapsfrompk4 c2d64874

2020-11-20 12:11:34

greebo

Details Diff
0005108: Extend IArchiveFileInfoProvider interface. Add corresponding unit tests. Affected Issues
0005108
mod - include/iarchive.h Diff File
mod - include/ifilesystem.h Diff File
mod - radiantcore/vfs/DirectoryArchive.cpp Diff File
mod - radiantcore/vfs/DirectoryArchive.h Diff File
mod - radiantcore/vfs/ZipArchive.cpp Diff File
mod - radiantcore/vfs/ZipArchive.h Diff File
mod - test/VFS.cpp Diff File

DarkRadiant: openmapsfrompk4 57154116

2020-11-20 12:30:31

greebo

Details Diff
0005108: Show the containing PK4 archive of non-physical files.
Handle double-clicking PK4s that are located in external directories.
Affected Issues
0005108
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/Populator.cpp Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - radiant/ui/mapselector/MapSelector.cpp Diff File

DarkRadiant: openmapsfrompk4 57e3a4e4

2020-11-20 13:01:01

greebo

Details Diff
0005108: Add MapSelector::Result structure to contain more info about the selected map file Affected Issues
0005108
mod - libs/wxutil/fsview/FileSystemView.cpp Diff File
mod - libs/wxutil/fsview/FileSystemView.h Diff File
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.h Diff File

DarkRadiant: openmapsfrompk4 6e5b0f30

2020-11-21 05:36:45

greebo

Details Diff
0005108: Add "altar" test resources, which will be used for some integration tests Affected Issues
0005108
add - test/resources/tdm/altar.pk4 Diff File
add - test/resources/tdm/maps/altar.darkradiant Diff File
add - test/resources/tdm/maps/altar.map Diff File

DarkRadiant: openmapsfrompk4 f5b63f27

2020-11-21 07:10:20

greebo

Details Diff
0005108: Start rigging some unit tests that are checking that map loading extracts all the elements we expect Affected Issues
0005108
mod - test/Makefile.am Diff File
add - test/MapSavingLoading.cpp Diff File
mod - test/TestContext.h Diff File
mod - test/algorithm/Scene.h Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 b51b6b79

2020-11-21 07:21:21

greebo

Details Diff
0005108: More test cases checking OpenMap command behaviour Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 8fd53aa9

2020-11-21 07:31:38

greebo

Details Diff
0005108: Add unit test checking whether opening a file from a mod PK4 is working Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File
mod - test/resources/tdm/altar.pk4 Diff File

DarkRadiant: openmapsfrompk4 a1005ec0

2020-11-21 08:00:36

greebo

Details Diff
0005108: Start working on map saving tests Affected Issues
0005108
mod - radiantcore/map/Map.cpp Diff File
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 9aef1fd2

2020-11-22 05:01:01

greebo

Details Diff
0005108: More test cases Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 62ab0e1c

2020-11-26 05:50:24

greebo

Details Diff
0005108: Add test case covering save copy as, using different formats. Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 f0965077

2020-11-26 10:55:53

greebo

Details Diff
0005108: Add test case to cover map format switch and modified status handling Affected Issues
0005108
mod - test/MapExport.cpp Diff File
mod - test/MapSavingLoading.cpp Diff File
mod - test/algorithm/Scene.h Diff File
add - test/algorithm/XmlUtils.h Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 439f2909

2020-11-26 11:13:15

greebo

Details Diff
0005108: Move NodeCounter helper to separate file Affected Issues
0005108
mod - radiantcore/map/MapResource.cpp Diff File
add - radiantcore/map/NodeCounter.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 ade784b1

2020-11-26 11:18:54

greebo

Details Diff
0005108: Remove static info file extension member, replace with static method Affected Issues
0005108
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File

DarkRadiant: openmapsfrompk4 fad07016

2020-11-26 13:44:54

greebo

Details Diff
0005108: Add tests to check if layer information is preserved between map saving and loading
Refactor tests to reduce code duplication.
Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File
add - test/algorithm/Primitives.h Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 5e01b6e1

2020-11-26 14:56:10

greebo

Details Diff
0005108: Add tests covering backup file handling. Change MapSavingTests to clean up after each case, such that the resource folder doesn't get filled up with clutter. Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 08365288

2020-11-26 15:10:06

greebo

Details Diff
0005108: Create map backup handling test for .mapx files Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 65f9d566

2020-11-26 15:49:18

greebo

Details Diff
0005108: Use the common getInfoFileExtension() method Affected Issues
0005108
mod - radiantcore/map/MapResource.cpp Diff File

DarkRadiant: openmapsfrompk4 0d4cbc42

2020-11-27 03:06:37

greebo

Details Diff
0005108: Check that saving works when opening a map in both mod-relative and absolute paths Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 c83ce131

2020-11-27 03:18:20

greebo

Details Diff
0005108: Remove unneeded member MapResource::_originalName Affected Issues
0005108
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File

DarkRadiant: openmapsfrompk4 86bb90c0

2020-11-27 03:48:24

greebo

Details Diff
0005108: Refactor MapResource and add some documentation.
Add map loading test passing an invalid resource path pointing to a folder, which made the MapResource crash.
Fixed the crash by throwing the correct exception type as mentioned in the docs.
Affected Issues
0005108
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 4ef43f78

2020-11-27 04:05:34

greebo

Details Diff
0005108: Fix MapResource's file extension calculation, since the resource path can contain ".." that might fool os::getExtension() Affected Issues
0005108
mod - radiantcore/map/MapResource.cpp Diff File

DarkRadiant: openmapsfrompk4 7e63672d

2020-11-27 04:07:41

greebo

Details Diff
0005108: Remove redundant checks, openFileStream will throw exceptions anyway Affected Issues
0005108
mod - radiantcore/map/MapResource.cpp Diff File
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 c3a01d03

2020-11-27 12:03:30

greebo

Details Diff
0005108: Use std::ifstream to read from absolute filesystem paths instead of the custom TextFileInputStream. Affected Issues
0005108
mod - libs/debugging/ScopedDebugTimer.h Diff File
mod - plugins/sound/SoundPlayer.cpp Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/MapResource.cpp Diff File

DarkRadiant: openmapsfrompk4 d99aea47

2020-11-28 02:45:50

greebo

Details Diff
0005108: Add test case loading a map without info file Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 36599788

2020-11-28 03:03:51

greebo

Details Diff
0005108: Start moving the stream loading method to a new MapResourceLoader class. The physical file handling part remains in MapResource. Affected Issues
0005108
mod - radiantcore/map/MapResource.cpp Diff File
add - radiantcore/map/MapResourceLoader.h Diff File
mod - radiantcore/map/algorithm/MapImporter.cpp Diff File
mod - radiantcore/map/algorithm/MapImporter.h Diff File
mod - test/MapSavingLoading.cpp Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 d1a3727f

2020-11-28 03:17:46

greebo

Details Diff
0005108: Move implementation to .cpp file, remove migrated code from MapResource class. Affected Issues
0005108
mod - radiantcore/Makefile.am Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File
add - radiantcore/map/MapResourceLoader.cpp Diff File
mod - radiantcore/map/MapResourceLoader.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 e56d7a7b

2020-11-28 05:14:01

greebo

Details Diff
0005108: Refactor stream instantation into a separate MapResourceStream implementation, taking care of the VFS vs. physical file switching. Affected Issues
0005108
add - libs/stream/MapResourceStream.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 db49aa7f

2020-11-28 05:35:59

greebo

Details Diff
0005108: Streamline exception handling a bit, reducing the amount of catch blocks Affected Issues
0005108
mod - include/imapresource.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResourceLoader.cpp Diff File
mod - radiantcore/map/MapResourceLoader.h Diff File

DarkRadiant: openmapsfrompk4 c12db2bf

2020-11-28 06:31:36

greebo

Details Diff
0005108: Add unit test checking the user being able to cancel the map loading process Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 753549d1

2020-11-28 07:53:47

greebo

Details Diff
0005108: Add (nonfunctional) OpenMapFromArchive command, plus some refactoring and shifting code around Affected Issues
0005108
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File

DarkRadiant: openmapsfrompk4 d9f4daef

2020-11-29 03:39:40

greebo

Details Diff
0005108: Add ArchivedMapResource specialisation, which will load the map from any PAK file.
Add two virtual method to be overridden by the ArchivedMapResource
Affected Issues
0005108
mod - include/imapresource.h Diff File
mod - radiant/ui/prefabselector/PrefabSelector.cpp Diff File
add - radiantcore/map/ArchivedMapResource.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File
mod - radiantcore/map/MapResourceManager.cpp Diff File
mod - radiantcore/map/MapResourceManager.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 1f5a51f9

2020-11-29 04:02:14

greebo

Details Diff
0005108: First working implementation Affected Issues
0005108
mod - libs/stream/MapResourceStream.h Diff File
mod - radiantcore/map/ArchivedMapResource.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File

DarkRadiant: openmapsfrompk4 cba0b361

2020-11-29 04:24:55

greebo

Details Diff
0005108: Double clicking a file will attempt to open it Affected Issues
0005108
mod - radiant/ui/mapselector/MapSelector.cpp Diff File

DarkRadiant: openmapsfrompk4 3d31502d

2020-11-29 11:06:02

greebo

Details Diff
0005108: Add unit test cases covering OpenMapFromArchive Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File
add - test/resources/map_loading_test.pk4 Diff File

DarkRadiant: openmapsfrompk4 f77b54a8

2020-11-29 11:48:13

greebo

Details Diff
0005108: Introduce IMapResource::isReadOnly which will be returning true for maps that cannot be saved to the same location they've been loaded from. Affected Issues
0005108
mod - include/imapresource.h Diff File
mod - radiantcore/map/ArchivedMapResource.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File

DarkRadiant: openmapsfrompk4 f152515b

2020-11-29 11:55:40

greebo

Details Diff
0005108: Add unit test checking the file selection dialog is coming up when saving an archived map Affected Issues
0005108
mod - radiantcore/map/ArchivedMapResource.h Diff File
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 390e11e6

2020-11-29 13:05:17

greebo

Details Diff
0005108: Re-implement the Map::saveAs algorithm to create a new resource instance, since the existing resource might be a read-only one.
Unit tests extended.
Affected Issues
0005108
mod - include/imapresource.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: openmapsfrompk4 07aed612

2020-11-29 17:54:03

greebo

Details Diff
0005108: Change dialog buttons, such that clicking OK with a PK4 selected will open that archive. Affected Issues
0005108
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.h Diff File

DarkRadiant: openmapsfrompk4 4bd351da

2020-11-29 18:25:36

greebo

Details Diff
0005108: Move ArchivedMapResource implementation to .cpp file.
Prevent saving of read-only resources.
Affected Issues
0005108
mod - radiantcore/Makefile.am Diff File
add - radiantcore/map/ArchivedMapResource.cpp Diff File
mod - radiantcore/map/ArchivedMapResource.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: openmapsfrompk4 9902de7b

2020-11-30 03:10:55

greebo

Details Diff
0005108: Linux compilation fixes Affected Issues
0005108
mod - radiant/Makefile.am Diff File
mod - radiant/ui/mapselector/MapSelector.cpp Diff File
mod - radiant/ui/mapselector/MapSelector.h Diff File
mod - radiantcore/map/MapResourceLoader.cpp Diff File

DarkRadiant: openmapsfrompk4 1b0fb803

2020-11-30 03:27:47

greebo

Details Diff
0005108: Fix unit tests Affected Issues
0005108
mod - test/MapSavingLoading.cpp Diff File

DarkRadiant: master c9c505a8

2020-11-30 03:57:11

greebo

Details Diff
0005108: Fix unit tests after TestContext API change Affected Issues
0005108
mod - radiantcore/settings/GameManager.cpp Diff File
mod - test/MapSavingLoading.cpp Diff File
mod - test/VFS.cpp Diff File

Issue History

Date Modified Username Field Change
05.01.2020 13:54 Dragofer New Issue
06.01.2020 04:30 greebo Status new => acknowledged
06.01.2020 04:30 greebo Note Added: 0012085
06.01.2020 22:48 Dragofer Note Added: 0012098
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 749028cc
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 e537c7b8
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 5338be7a
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 2090b07b
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 908e2f31
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 b4a8a2ee
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 58f9059a
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 94a75151
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 53dd96c0
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 31bfaa91
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 a8bbfce6
17.11.2020 08:04 greebo Changeset attached => DarkRadiant openmapsfrompk4 3908cce4
17.11.2020 08:04 greebo Assigned To => greebo
17.11.2020 08:04 greebo Status acknowledged => assigned
17.11.2020 08:05 greebo Target Version => 2.10.0
17.11.2020 08:30 greebo Changeset attached => DarkRadiant openmapsfrompk4 6df3f915
17.11.2020 12:12 greebo Changeset attached => DarkRadiant openmapsfrompk4 cb121ff1
17.11.2020 12:53 greebo Changeset attached => DarkRadiant openmapsfrompk4 88e372be
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 49b4ba3e
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 daaeea45
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 1de9630a
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 85f8cc01
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 df6d9567
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 9d256795
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 c04ede4f
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 e509e15e
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 97335c5c
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 8334847f
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 e0982467
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 3c16feb1
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 53f3c0c7
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 b7b182b7
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 96b65000
18.11.2020 05:01 greebo Changeset attached => DarkRadiant openmapsfrompk4 a4ece374
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 dbcb3ffd
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 f47cb2c8
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 ab5307a6
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 0d9be848
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 d1109394
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 c4388709
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 4de5833b
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 11cb2b13
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 5b5f1d88
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 0dbd819c
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 ae431ff6
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 0aa6d018
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 dddbeb27
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 0932b02c
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 02991dbb
19.11.2020 08:43 greebo Changeset attached => DarkRadiant openmapsfrompk4 f8265f0b
19.11.2020 08:44 greebo Changeset removed DarkRadiant openmapsfrompk4 f8265f0b =>
19.11.2020 08:45 greebo Changeset removed DarkRadiant openmapsfrompk4 02991dbb =>
19.11.2020 08:45 greebo Changeset removed DarkRadiant openmapsfrompk4 96b65000 =>
19.11.2020 08:46 greebo Changeset removed DarkRadiant openmapsfrompk4 749028cc =>
19.11.2020 08:46 greebo Changeset removed DarkRadiant openmapsfrompk4 49b4ba3e =>
19.11.2020 08:47 greebo Changeset removed DarkRadiant openmapsfrompk4 e537c7b8 =>
19.11.2020 08:47 greebo Changeset removed DarkRadiant openmapsfrompk4 daaeea45 =>
19.11.2020 08:48 greebo Changeset removed DarkRadiant openmapsfrompk4 5338be7a =>
19.11.2020 08:48 greebo Changeset removed DarkRadiant openmapsfrompk4 1de9630a =>
19.11.2020 08:48 greebo Changeset removed DarkRadiant openmapsfrompk4 85f8cc01 =>
19.11.2020 08:48 greebo Changeset removed DarkRadiant openmapsfrompk4 2090b07b =>
19.11.2020 08:49 greebo Changeset removed DarkRadiant openmapsfrompk4 df6d9567 =>
19.11.2020 08:49 greebo Changeset removed DarkRadiant openmapsfrompk4 908e2f31 =>
19.11.2020 08:49 greebo Changeset removed DarkRadiant openmapsfrompk4 b4a8a2ee =>
19.11.2020 08:49 greebo Changeset removed DarkRadiant openmapsfrompk4 9d256795 =>
19.11.2020 08:49 greebo Changeset removed DarkRadiant openmapsfrompk4 58f9059a =>
19.11.2020 08:49 greebo Changeset removed DarkRadiant openmapsfrompk4 c04ede4f =>
19.11.2020 08:50 greebo Changeset removed DarkRadiant openmapsfrompk4 94a75151 =>
19.11.2020 08:50 greebo Changeset removed DarkRadiant openmapsfrompk4 e509e15e =>
19.11.2020 08:50 greebo Changeset removed DarkRadiant openmapsfrompk4 97335c5c =>
19.11.2020 08:50 greebo Changeset removed DarkRadiant openmapsfrompk4 53dd96c0 =>
19.11.2020 08:50 greebo Changeset removed DarkRadiant openmapsfrompk4 31bfaa91 =>
19.11.2020 08:50 greebo Changeset removed DarkRadiant openmapsfrompk4 8334847f =>
19.11.2020 08:50 greebo Changeset removed DarkRadiant openmapsfrompk4 e0982467 =>
19.11.2020 08:50 greebo Changeset removed DarkRadiant openmapsfrompk4 a8bbfce6 =>
19.11.2020 08:51 greebo Changeset removed DarkRadiant openmapsfrompk4 3908cce4 =>
19.11.2020 08:51 greebo Changeset removed DarkRadiant openmapsfrompk4 3c16feb1 =>
19.11.2020 08:51 greebo Changeset removed DarkRadiant openmapsfrompk4 6df3f915 =>
19.11.2020 08:51 greebo Changeset removed DarkRadiant openmapsfrompk4 53f3c0c7 =>
19.11.2020 08:51 greebo Changeset removed DarkRadiant openmapsfrompk4 cb121ff1 =>
19.11.2020 08:51 greebo Changeset removed DarkRadiant openmapsfrompk4 b7b182b7 =>
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 19878636
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 f183d3b7
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 933f954a
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 b510768c
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 d58ed929
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 0f615a18
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 96e15e3c
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 61482364
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 3df1215e
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 9f7fcc73
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 a12489e3
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 5fd0dcb5
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 1492339a
20.11.2020 09:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 07aa55ab
20.11.2020 12:30 greebo Changeset attached => DarkRadiant openmapsfrompk4 49b50330
20.11.2020 12:30 greebo Changeset attached => DarkRadiant openmapsfrompk4 c2d64874
20.11.2020 12:30 greebo Changeset attached => DarkRadiant openmapsfrompk4 57154116
21.11.2020 07:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 57e3a4e4
21.11.2020 07:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 018e7fd6
21.11.2020 07:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 4c59395e
21.11.2020 07:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 91b70846
21.11.2020 07:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 82703c00
21.11.2020 07:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 90e0b1a7
21.11.2020 08:01 greebo Changeset removed DarkRadiant openmapsfrompk4 018e7fd6 =>
21.11.2020 08:01 greebo Changeset removed DarkRadiant openmapsfrompk4 4c59395e =>
21.11.2020 08:01 greebo Changeset removed DarkRadiant openmapsfrompk4 91b70846 =>
21.11.2020 08:01 greebo Changeset removed DarkRadiant openmapsfrompk4 82703c00 =>
21.11.2020 08:01 greebo Changeset removed DarkRadiant openmapsfrompk4 90e0b1a7 =>
21.11.2020 08:02 greebo Changeset attached => DarkRadiant openmapsfrompk4 6e5b0f30
21.11.2020 08:02 greebo Changeset attached => DarkRadiant openmapsfrompk4 f5b63f27
21.11.2020 08:02 greebo Changeset attached => DarkRadiant openmapsfrompk4 b51b6b79
21.11.2020 08:02 greebo Changeset attached => DarkRadiant openmapsfrompk4 8fd53aa9
21.11.2020 08:02 greebo Changeset attached => DarkRadiant openmapsfrompk4 a1005ec0
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 9aef1fd2
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 62ab0e1c
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 f0965077
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 439f2909
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 ade784b1
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 fad07016
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 5e01b6e1
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 08365288
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 65f9d566
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 0d4cbc42
27.11.2020 03:18 greebo Changeset attached => DarkRadiant openmapsfrompk4 c83ce131
27.11.2020 04:28 greebo Changeset attached => DarkRadiant openmapsfrompk4 86bb90c0
27.11.2020 04:28 greebo Changeset attached => DarkRadiant openmapsfrompk4 4ef43f78
27.11.2020 04:28 greebo Changeset attached => DarkRadiant openmapsfrompk4 7e63672d
28.11.2020 06:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 c3a01d03
28.11.2020 06:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 d99aea47
28.11.2020 06:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 36599788
28.11.2020 06:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 d1a3727f
28.11.2020 06:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 e56d7a7b
28.11.2020 06:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 db49aa7f
28.11.2020 06:31 greebo Changeset attached => DarkRadiant openmapsfrompk4 c12db2bf
29.11.2020 04:25 greebo Changeset attached => DarkRadiant openmapsfrompk4 753549d1
29.11.2020 04:25 greebo Changeset attached => DarkRadiant openmapsfrompk4 d9f4daef
29.11.2020 04:25 greebo Changeset attached => DarkRadiant openmapsfrompk4 1f5a51f9
29.11.2020 04:25 greebo Changeset attached => DarkRadiant openmapsfrompk4 cba0b361
29.11.2020 13:05 greebo Changeset attached => DarkRadiant openmapsfrompk4 3d31502d
29.11.2020 13:05 greebo Changeset attached => DarkRadiant openmapsfrompk4 f77b54a8
29.11.2020 13:05 greebo Changeset attached => DarkRadiant openmapsfrompk4 f152515b
29.11.2020 13:05 greebo Changeset attached => DarkRadiant openmapsfrompk4 390e11e6
29.11.2020 17:59 greebo Changeset attached => DarkRadiant openmapsfrompk4 07aed612
29.11.2020 18:25 greebo Changeset attached => DarkRadiant openmapsfrompk4 4bd351da
30.11.2020 03:28 greebo Changeset attached => DarkRadiant openmapsfrompk4 9902de7b
30.11.2020 03:28 greebo Changeset attached => DarkRadiant openmapsfrompk4 1b0fb803
30.11.2020 03:44 greebo Status assigned => resolved
30.11.2020 03:44 greebo Resolution open => fixed
30.11.2020 03:44 greebo Fixed in Version => 2.10.0
30.11.2020 04:09 greebo Changeset attached => DarkRadiant master c9c505a8