View Issue Details

IDProjectCategoryView StatusLast Update
0005124DarkRadiantDesign/Codingpublic18.01.2021 06:26
ReporterBikerdude Assigned Toorbweaver  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.6.0 
Fixed in Version2.10.0 
Summary0005124: DR slow/laggy to move light sources around - on large maps
DescriptionThis is an old bug - if you have to move a light source around or adjust its light radious - its very very laggy. Current work around is to select the light and/or the objecting near where you moving the light to and press shift-h then its smooth again.
Steps To Reproduce- Open DR.
- Go into Orthoview.
- Select any light source (models or pure source)
- press LMB and move the entity around
Additional InformationMy guess is when the entity count goes above a certain paint DR is running into some kind of issue, that causing the lag.
TagsNo tags attached.

Activities

Bikerdude

Bikerdude

01.05.2020 12:38

reporter   ~0012439

Last edited: 01.05.2020 12:39

View 2 revisions

Is it possible to know whats causing the lag, or is it just not realisticlly fixable..?
greebo

greebo

01.05.2020 12:49

administrator   ~0012443

There's a lot going on when manipulating lights in large maps. It's due to the way DR is keeping track of lit objects, which is in fact very inefficient.
It can be fixed by changing the way it's done, but of course this is not exactly trivial.
Bikerdude

Bikerdude

03.11.2020 12:30

reporter   ~0012856

Well the work around I have for this is to press 'shift-H' to hide everything bar the light and or model I am trying to move around.
orbweaver

orbweaver

17.01.2021 20:07

developer   ~0013477

Last edited: 17.01.2021 20:13

View 3 revisions

@Bikerdude, does this still happen in the latest release? In my testing with the Painter's Wife, I don't see any more lag dragging a light around or adjusting its radius than any other object, at least in regular 3D fullbright mode. In lighting preview mode it is very laggy (as low as 2 FPS) but this same low framerate appears when just moving the camera around, so it doesn't appear to be a specific problem with lights (and we know the lighting preview mode is horribly slow).

There were some significant architectural changes made to light handling in recent months, and I am wondering if this might have unintentionally fixed this issue — in particular, if you are not using lighting preview mode (which most mappers don't it seems), there should be NO lighting calculations whatsoever.
Bikerdude

Bikerdude

17.01.2021 22:31

reporter   ~0013478

Last edited: 17.01.2021 22:32

View 2 revisions

Well whadya know, I selected a bunch of lights, brushes, models and other entities and moved them all at the same time with no lag. And this with ALL of the map layers visible...!!!

In 2.8 I can't even move one light.

I have asked Dragofer/Amadeus to confirm, but I would see this can be closed :-)
Dragofer

Dragofer

17.01.2021 23:03

developer   ~0013479

Last edited: 17.01.2021 23:03

View 2 revisions

I haven't had issues with moving lights in that map on any DR version, so wouldn't be able to confirm that anything has changed. Always worked fine.

Issue History

Date Modified Username Field Change
12.01.2020 12:54 Bikerdude New Issue
01.05.2020 12:38 Bikerdude Note Added: 0012439
01.05.2020 12:39 Bikerdude Note Edited: 0012439 View Revisions
01.05.2020 12:49 greebo Note Added: 0012443
03.11.2020 12:30 Bikerdude Note Added: 0012856
17.01.2021 20:07 orbweaver Assigned To => orbweaver
17.01.2021 20:07 orbweaver Status new => feedback
17.01.2021 20:07 orbweaver Note Added: 0013477
17.01.2021 20:08 orbweaver Note Edited: 0013477 View Revisions
17.01.2021 20:13 orbweaver Note Edited: 0013477 View Revisions
17.01.2021 22:31 Bikerdude Note Added: 0013478
17.01.2021 22:31 Bikerdude Status feedback => assigned
17.01.2021 22:32 Bikerdude Note Edited: 0013478 View Revisions
17.01.2021 23:03 Dragofer Note Added: 0013479
17.01.2021 23:03 Dragofer Note Edited: 0013479 View Revisions
18.01.2021 06:26 Dragofer Status assigned => resolved
18.01.2021 06:26 Dragofer Resolution open => fixed
18.01.2021 06:26 Dragofer Fixed in Version => 2.10.0