View Issue Details

IDProjectCategoryView StatusLast Update
0005174DarkRadiantDesign/Codingpublic08.11.2020 18:34
ReporterVanishedOne Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
Product Version2.7.0 
Fixed in Version2.8.0 
Summary0005174: Loading error caused by non-Latin character in filename
DescriptionRecently DR started giving the following error on startup: "Unhandled unknown exception; terminating the thread in which it happened." It would do it again if I tried to use the model viewer, and then the model list would fail to load. I tracked it down to a .zip file I'd recently placed under /models/ (it contains a Creative Commons licensed asset I was going to consider converting for an FM) which contained the name of the asset's creator, "Murat yılmaz" - note the dotless I. https://en.wikipedia.org/wiki/Dotted_and_dotless_I

I tried moving the file out of /models/ and into my main /darkmod/ directory--which caused DR to crash outright on startup. I don't expect DR to load filenames with arbitrary Unicode, but it seems their mere presence can render DR unusable.
TagsNo tags attached.

Activities

greebo

greebo

24.03.2020 05:28

administrator   ~0012304

Last edited: 24.03.2020 05:49

View 2 revisions

I can confirm the crash. It appears that the TDM engine is not able to process PK4 files containing unicode chars either, so I'm going to adjust DR to skip that file as well, emitting a warning in the console maybe.

Related Changesets

DarkRadiant: master b1b390aa

2020-03-24 18:32:28

greebo

Details Diff
Fix 0005174: DR crash on startup when encountering a file in any VFS search path with foreign characters in their filename.
Since the engine doesn't load these files, DR will issue a warning and skip that file as well.
Affected Issues
0005174
mod - radiant/vfs/Doom3FileSystem.cpp Diff File

DarkRadiant: master 694b863c

2020-03-24 18:44:57

greebo

Details Diff
0005174: Fix crash in model populator thread (or any other VFS-traversing code for that matter) when encountering non-latin characters in filenames Affected Issues
0005174
mod - radiant/vfs/DirectoryArchive.cpp Diff File

DarkRadiant: utf8_test 024cadc8

2020-04-06 04:46:02

greebo

Details Diff
0005174: Fix compilation error in Linux Affected Issues
0005174
add - libs/string/encoding.h Diff File
mod - radiant/vfs/DirectoryArchive.cpp Diff File
mod - radiant/vfs/Doom3FileSystem.cpp Diff File

DarkRadiant: master 7fbb58cf

2020-04-06 04:46:02

greebo

Details Diff
0005174: Fix compilation error in Linux Affected Issues
0005174
add - libs/string/encoding.h Diff File
mod - radiant/vfs/DirectoryArchive.cpp Diff File
mod - radiant/vfs/Doom3FileSystem.cpp Diff File

DarkRadiant: master f708ef70

2020-04-06 04:55:02

greebo

Details Diff
0005174: Add new file to VC++ projet Affected Issues
0005174
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: master 31dfbb68

2020-04-06 05:47:59

greebo

Details Diff
0005174: Silence a VC++ warning about wstring_convert being deprecated. Add inclusion guard to header. Affected Issues
0005174
mod - libs/string/encoding.h Diff File
mod - tools/msvc/properties/DarkRadiant Base.props Diff File

Issue History

Date Modified Username Field Change
09.03.2020 21:54 VanishedOne New Issue
11.03.2020 14:49 greebo Status new => acknowledged
24.03.2020 05:14 greebo Status acknowledged => confirmed
24.03.2020 05:28 greebo Note Added: 0012304
24.03.2020 05:49 greebo Note Edited: 0012304 View Revisions
24.03.2020 18:45 greebo Changeset attached => DarkRadiant master b1b390aa
24.03.2020 18:45 greebo Assigned To => greebo
24.03.2020 18:45 greebo Resolution open => fixed
24.03.2020 18:45 greebo Status confirmed => assigned
24.03.2020 18:46 greebo Changeset attached => DarkRadiant master 694b863c
24.03.2020 18:46 greebo Status assigned => resolved
24.03.2020 18:46 greebo Fixed in Version => 2.8.0
06.04.2020 05:58 greebo Changeset attached => DarkRadiant master 31dfbb68
06.04.2020 05:58 greebo Changeset attached => DarkRadiant master f708ef70
06.04.2020 05:58 greebo Changeset attached => DarkRadiant utf8_test 024cadc8
06.04.2020 05:58 greebo Changeset attached => DarkRadiant master 7fbb58cf
08.11.2020 18:34 greebo Status resolved => closed