View Issue Details

IDProjectCategoryView StatusLast Update
0005209DarkRadiantGUIpublic08.11.2020 18:34
Reporterorbweaver Assigned Toorbweaver  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
Product Version2.7.0 
Target Version2.8.0Fixed in Version2.8.0 
Summary0005209: Modal dialogs can be too easily closed without saving settings
DescriptionModal dialogs currently have an 'X' close button which can be clicked by mistake resulting in the dialog closing immediately without prompting to save settings. This can result in data loss when performing complex operations in a dialog e.g. editing map objectives.

Reported by Geep on the forums:
https://forums.thedarkmod.com/index.php?/topic/3499-wishlist-for-darkradiant/page/28/&tab=comments#comment-443638
TagsNo tags attached.

Activities

orbweaver

orbweaver

06.04.2020 20:05

developer   ~0012335

Close button removed from modal dialogs in commit 8ee8e4213042057192b8a6d36f05c497b513b76b

Related Changesets

DarkRadiant: master 8ee8e421

2020-02-25 21:19:06

orbweaver

Details Diff
Remove close button from modal dialogs

A user reported that accidentally closing dialogs such as the Objectives editor
with the top-right close button can result in data loss, because the dialog
treats this as "Cancel" and does not prompt to save changes. Now the close
button is removed, so a user must explicitly choose to click one of the main
buttons at the bottom.

I don't know for sure whether the wxSYSTEM_MENU style is needed, but since it
was part of the wxDEFAULT_DIALOG_STYLE and I'm not in a position to test its
removal (it only has an effect on Windows according to the docs), it is left in
for now.
Affected Issues
0005209
mod - libs/wxutil/dialog/DialogBase.cpp Diff File

Issue History

Date Modified Username Field Change
06.04.2020 20:04 orbweaver New Issue
06.04.2020 20:04 orbweaver Status new => assigned
06.04.2020 20:04 orbweaver Assigned To => orbweaver
06.04.2020 20:05 orbweaver Note Added: 0012335
06.04.2020 20:06 orbweaver Summary Modal dialogs can be easily closed without saving settings => Modal dialogs can be too easily closed without saving settings
06.04.2020 20:07 orbweaver Status assigned => resolved
06.04.2020 20:07 orbweaver Resolution open => fixed
06.04.2020 20:07 orbweaver Fixed in Version => 2.8.0
07.04.2020 04:15 greebo Changeset attached => DarkRadiant master 8ee8e421
08.11.2020 18:34 greebo Status resolved => closed