View Issue Details

IDProjectCategoryView StatusLast Update
0005238The Dark ModGraphicspublic30.12.2020 17:46
Reportercabalistic Assigned Tocabalistic  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.08 
Target VersionTDM 2.09Fixed in VersionTDM 2.09 
Summary0005238: Reduce CPU draw call overhead in the backend
DescriptionDue to the number of frequent small draw calls issued by the engine - especially during interaction rendering - with regular state changes in-between (textures, uniforms, ...), the CPU overhead per draw calls is high and can easily starve the GPU, leading to wasted time. Experiments with more modern draw call setups have shown that we can significantly reduce this overhead and thereby also improve the GPU frame times. Although this will currently not immediately result in improved framerates (as long as com_smp is enabled, because in that case any savings are hidden behind the CPU time of the frontend), it is still a necessary step to realize higher framerates when we also further optimize the frontend.
TagsNo tags attached.

Relationships

parent of 0005476 assignedcabalistic Bindless Textures causes freezes and stutter when changing Anisotropic Filtering in a loaded Mission 
child of 0003684 new Investigate GPL Renderer Improvements 
Not all the children of this issue are yet resolved or closed.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
03.05.2020 11:08 cabalistic New Issue
03.05.2020 11:08 cabalistic Status new => assigned
03.05.2020 11:08 cabalistic Assigned To => cabalistic
02.07.2020 20:03 cabalistic Status assigned => resolved
02.07.2020 20:03 cabalistic Resolution open => fixed
02.07.2020 20:03 cabalistic Fixed in Version => TDM 2.09
30.12.2020 02:17 nbohr1more Relationship added child of 0003684
30.12.2020 17:46 nbohr1more Relationship added parent of 0005476