View Issue Details

IDProjectCategoryView StatusLast Update
0005346DarkRadiantMap Editingpublic27.10.2020 07:38
Reporterstgatilov Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.9.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0005346: TDM Game Connection Plugin
DescriptionFollowing the discussion in https://forums.thedarkmod.com/index.php?/topic/20493-connection-to-tdm-with-automation/

The game connection plugin can communicate with the running TDM game to facilitate tasks and perform camera synchronisation.
TagsNo tags attached.

Activities

Bikerdude

Bikerdude

09.10.2020 21:21

reporter   ~0012809

I have been playing with this for a few weeks and the changes made in DR dont always replicate in TDM. Whe n I get the time I will have to make a test map to demonstrate.
greebo

greebo

27.10.2020 04:09

administrator   ~0012843

Settings this to resolved until further feedback arrives.
Bikerdude

Bikerdude

27.10.2020 07:38

reporter   ~0012844

I haven't been using this function that much due to the automation not being consistent, which I think is more not understanding fully how I am supposed to be using it and wanting to just get on with mapping.

Related Changesets

DarkRadiant: master 27ffd544

2020-09-23 20:29:40

orbweaver


Committer: greebo Details Diff
0005346: Game connection UI initialisation happens in the plugin itself

The addition of game connection functionality to the menu, command manager and
event manager now happens in GameConnection::initialiseModule() rather than
elsewhere in DarkRadiant. This ensures that there is no Connection menu when
the plugin is not compiled or installed.
Affected Issues
0005346
mod - install/menu.xml Diff File
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File

DarkRadiant: master 0d1aa0cb

2020-09-24 19:45:43

orbweaver


Committer: greebo Details Diff
0005346: Remove IGameConnection interface and header

Now that GameConnection is a self-contained plugin, there is no further need
for a defined module interface.
Affected Issues
0005346
rm - include/igameconnection.h Diff File
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - plugins/dm.gameconnection/GameConnection.h Diff File

DarkRadiant: master 423f424b

2020-09-28 03:41:11

greebo

Details Diff
0005346: Partially apply 88085f5a56a4f396b88fb1df52187f1550a937c1 and 954dd4405d8a558b22c11622c23f7d8f634191c6from orbweaver/master.

- Move GameConnection into a separate plugin
- Add missing clsocket files to gameconnection plugin Makefile.am
Affected Issues
0005346
mod - configure.ac Diff File
mod - plugins/Makefile.am Diff File
add - plugins/dm.gameconnection/Makefile.am Diff File
mod - radiant/Makefile.am Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File

DarkRadiant: master d6b6a8fb

2020-09-28 16:21:39

greebo

Details Diff
0005346: Port most changes of commit 88085f5a56a4f396b88fb1df52187f1550a937c1 from orbweaver/master.
Create the VC++ project, adjust code to fit the recent architectural changes.
Affected Issues
0005346
mod - include/precompiled_main.h Diff File
mod - plugins/dm.gameconnection/DiffDoom3MapWriter.cpp Diff File
mod - plugins/dm.gameconnection/DiffDoom3MapWriter.h Diff File
mod - plugins/dm.gameconnection/DiffStatus.h Diff File
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - plugins/dm.gameconnection/MapObserver.cpp Diff File
mod - plugins/dm.gameconnection/MapObserver.h Diff File
mod - plugins/dm.gameconnection/clsocket/StatTimer.h Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - tools/msvc/DarkRadiant.sln Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File
mod - tools/msvc/dm.editing.vcxproj Diff File
add - tools/msvc/dm.gameconnection.vcxproj Diff File
add - tools/msvc/dm.gameconnection.vcxproj.filters Diff File

DarkRadiant: master 94453b04

2020-09-28 17:26:04

greebo

Details Diff
0005346: Extract the IMapExporter interface, and add IMap::createMapExporter method to return an instance to enable the game connection plugin to export the scene. Affected Issues
0005346
mod - include/imap.h Diff File
add - include/imapexporter.h Diff File
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/algorithm/MapExporter.cpp Diff File
mod - radiantcore/map/algorithm/MapExporter.h Diff File
mod - tools/msvc/dm.gameconnection.vcxproj Diff File
mod - tools/msvc/include.vcxproj Diff File

DarkRadiant: master ab23d19a

2020-09-29 04:08:11

greebo

Details Diff
0005346: Refactoring, move constants, make strings localisable. Affected Issues
0005346
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - plugins/dm.gameconnection/GameConnection.h Diff File

DarkRadiant: master a79ce7bb

2020-09-29 04:37:06

greebo

Details Diff
0005346: Insert Connection menu before the Help item Affected Issues
0005346
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File

DarkRadiant: master 97a1d374

2020-09-29 05:55:01

greebo

Details Diff
0005346: Fix a couple of compiler warnings Affected Issues
0005346
mod - plugins/dm.gameconnection/MessageTcp.cpp Diff File
mod - plugins/dm.gameconnection/MessageTcp.h Diff File
mod - plugins/dm.gameconnection/clsocket/Host.h Diff File
mod - plugins/dm.gameconnection/clsocket/PassiveSocket.cpp Diff File
mod - plugins/dm.gameconnection/clsocket/SimpleSocket.cpp Diff File
mod - tools/msvc/dm.gameconnection.vcxproj Diff File

DarkRadiant: master fa320d04

2020-09-29 15:50:39

greebo

Details Diff
0005346: Refactoring Affected Issues
0005346
mod - plugins/dm.gameconnection/DiffDoom3MapWriter.cpp Diff File
mod - plugins/dm.gameconnection/DiffDoom3MapWriter.h Diff File
mod - plugins/dm.gameconnection/DiffStatus.h Diff File
mod - plugins/dm.gameconnection/GameConnection.cpp Diff File
mod - plugins/dm.gameconnection/GameConnection.h Diff File
mod - plugins/dm.gameconnection/MapObserver.cpp Diff File
mod - plugins/dm.gameconnection/MapObserver.h Diff File

DarkRadiant: master 4627d4c6

2020-09-29 16:33:35

greebo

Details Diff
0005346: Fix a few crashes at shutdown, due to the worldspawn entity not carrying a name spawnarg.
Worldspawn key/values are not observed anymore.
Ignore the map root node when it is inserted or removed.
Affected Issues
0005346
mod - plugins/dm.gameconnection/MapObserver.cpp Diff File

DarkRadiant: master 9b670421

2020-09-29 19:39:47

orbweaver


Committer: greebo Details Diff
0005346: Linux compilation fixes.
Remove libtool-generated file.
Affected Issues
0005346
mod - include/imodule.h Diff File
mod - libs/module/ApplicationContextBase.cpp Diff File
mod - plugins/dm.gameconnection/clsocket/PassiveSocket.cpp Diff File
mod - radiant/Makefile.am Diff File
mod - radiant/camera/tools/JumpToObjectTool.h Diff File
rm - radiant/darkradiant Diff File
mod - radiant/eventmanager/MouseToolManager.cpp Diff File
mod - radiant/ui/DispatchEvent.h Diff File
mod - radiant/ui/ManipulatorToggle.h Diff File
mod - radiant/ui/overlay/Overlay.cpp Diff File
mod - radiant/ui/script/ScriptMenu.h Diff File
mod - radiant/ui/script/ScriptUserInterfaceModule.cpp Diff File
mod - radiant/xyview/XYWnd.cpp Diff File
mod - radiantcore/Makefile.am Diff File
mod - radiantcore/brush/csg/CSG.cpp Diff File
mod - radiantcore/camera/Camera.cpp Diff File
mod - radiantcore/rendersystem/OpenGLRenderSystem.cpp Diff File

DarkRadiant: master 80d60d4c

2020-09-30 15:40:16

greebo

Details Diff
0005346: Another attempt to fix the SOCKET initialisation, the recent commit was breaking the Windows build. Affected Issues
0005346
mod - plugins/dm.gameconnection/clsocket/PassiveSocket.cpp Diff File

Issue History

Date Modified Username Field Change
28.09.2020 17:24 greebo New Issue
29.09.2020 04:32 greebo Changeset attached => DarkRadiant master 423f424b
29.09.2020 04:32 greebo Changeset attached => DarkRadiant master 27ffd544
29.09.2020 04:32 greebo Changeset attached => DarkRadiant master 0d1aa0cb
29.09.2020 04:32 greebo Changeset attached => DarkRadiant master d6b6a8fb
29.09.2020 04:32 greebo Changeset attached => DarkRadiant master 94453b04
29.09.2020 05:55 greebo Changeset attached => DarkRadiant master ab23d19a
29.09.2020 05:55 greebo Changeset attached => DarkRadiant master a79ce7bb
29.09.2020 05:55 greebo Changeset attached => DarkRadiant master 97a1d374
29.09.2020 05:55 greebo Status new => confirmed
29.09.2020 05:55 greebo Product Version => 2.9.0
29.09.2020 05:55 greebo Target Version => 2.9.0
29.09.2020 16:33 greebo Changeset attached => DarkRadiant master fa320d04
29.09.2020 16:33 greebo Changeset attached => DarkRadiant master 4627d4c6
30.09.2020 15:40 greebo Changeset attached => DarkRadiant master 9b670421
30.09.2020 15:40 greebo Changeset attached => DarkRadiant master 80d60d4c
02.10.2020 16:21 greebo Reporter greebo => stgatilov
09.10.2020 21:21 Bikerdude Note Added: 0012809
27.10.2020 04:09 greebo Assigned To => stgatilov
27.10.2020 04:09 greebo Status confirmed => resolved
27.10.2020 04:09 greebo Resolution open => fixed
27.10.2020 04:09 greebo Fixed in Version => 2.9.0
27.10.2020 04:09 greebo Note Added: 0012843
27.10.2020 07:38 Bikerdude Note Added: 0012844