View Issue Details

IDProjectCategoryView StatusLast Update
0005372DarkRadiantGUIpublic18.11.2020 04:01
ReporterSpooks Assigned To 
PrioritynormalSeveritynormalReproducibilityrandom
Status acknowledgedResolutionreopened 
Product Version2.8.0 
Summary0005372: Orthoview brushes sometimes display as black
DescriptionI have the Black & Green color scheme for the orthoview grid, slightly modified. Black bg, grey grid, light green brushes, orange entities, so on. Two times now, I have started the program and opened a map only to have the "brushes" color (and only them) be "reset" to black. I put "reset" in scare quotes because I can't be sure, but I am guessing it reverts to the black of the default color scheme.
Steps To ReproduceI don't know how to reproduce this one reliably. A program restart fixes it.
TagsNo tags attached.

Activities

greebo

greebo

03.11.2020 18:00

administrator   ~0012864

I can force this to happen when trying to drag a brush immediately after the orthoview is shown. Usually there is short lag in the application after startup before it accepts the newly drawn brush.
The reason is that the brush colour helper is executed during the app's idle phase, which might be just a tad to late in some scenarios. If worldspawn brushes are to be rendered before that idle event kicks in, you get the default worldspawn brush colour, which is black, as defined in its entityDef.

I can see if I can move that colour handling code to a more appropriate place which doesn't rely on the app's idle event.
Spooks

Spooks

11.11.2020 08:46

reporter   ~0012890

2.9.0 pre2. Encountered it again. Whoops. Reopening.

Related Changesets

DarkRadiant: 2.9.0 df3e421d

2020-11-03 20:02:17

greebo

Details Diff
0005372: Attempt to fix brushes occasionally falling back to their black wire shader colour Affected Issues
0005372
mod - include/ieclass.h Diff File
mod - radiant/Makefile.am Diff File
mod - radiant/render/OpenGLModule.cpp Diff File
add - radiant/ui/EntityClassColourManager.cpp Diff File
mod - radiant/ui/EntityClassColourManager.h Diff File
mod - radiantcore/eclass/Doom3EntityClass.cpp Diff File
mod - radiantcore/eclass/Doom3EntityClass.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/EntityNode.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

Issue History

Date Modified Username Field Change
29.10.2020 23:03 Spooks New Issue
30.10.2020 16:52 greebo Status new => acknowledged
03.11.2020 18:00 greebo Note Added: 0012864
03.11.2020 20:01 greebo Assigned To => greebo
03.11.2020 20:01 greebo Status acknowledged => assigned
03.11.2020 20:01 greebo Target Version => 2.9.0
03.11.2020 20:03 greebo Changeset attached => DarkRadiant 2.9.0 df3e421d
03.11.2020 20:03 greebo Status assigned => resolved
03.11.2020 20:03 greebo Resolution open => fixed
03.11.2020 20:03 greebo Fixed in Version => 2.9.0
11.11.2020 08:46 Spooks Status resolved => assigned
11.11.2020 08:46 Spooks Resolution fixed => reopened
11.11.2020 08:46 Spooks Note Added: 0012890
18.11.2020 04:01 greebo Assigned To greebo =>
18.11.2020 04:01 greebo Status assigned => acknowledged
18.11.2020 04:01 greebo Fixed in Version 2.9.0 =>
18.11.2020 04:01 greebo Target Version 2.9.0 =>