View Issue Details

IDProjectCategoryView StatusLast Update
0005430DarkRadiantGUIpublic13.12.2020 06:22
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.9.1 
Target Version2.10.0Fixed in Version2.10.0 
Summary0005430: World geometry is blue and cannot be changed when no worldspawn entityDef is defined
DescriptionReported here: https://forums.thedarkmod.com/index.php?/topic/20650-2d-views-geometry-is-blue-lines/

All the worldspawn brushes will fall back using the hardcoded blue-ish value <0.3 0.3 1> as wire shader when no entityDef is defined anywhere. The colour cannot be adjusted using the Colour Scheme editor, which makes mapping much harder on darker orthoview background colours.
TagsNo tags attached.

Activities

greebo

greebo

23.11.2020 03:52

administrator  

greebo

greebo

23.11.2020 03:53

administrator   ~0013012

Attached above is a dump of the messed up colours.xml file.

Related Changesets

DarkRadiant: master 3212c01c

2020-11-23 04:54:37

greebo

Details Diff
0005430: Start writing some unit tests checking the colour schemes Affected Issues
0005430
add - test/ColourSchemes.cpp Diff File
mod - test/Makefile.am Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: master 45a1d67c

2020-11-23 05:50:56

greebo

Details Diff
0005430: More colour scheme test cases Affected Issues
0005430
mod - test/ColourSchemes.cpp Diff File

DarkRadiant: master 117beb68

2020-11-23 07:02:36

greebo

Details Diff
0005430: Rename test resource path to test project path, since it directly returns the path to the tdm/ resources Affected Issues
0005430
mod - test/ColourSchemes.cpp Diff File
mod - test/ModelExport.cpp Diff File
mod - test/RadiantTest.h Diff File
mod - test/TestContext.h Diff File

DarkRadiant: master fd2fdce8

2020-11-23 07:05:50

greebo

Details Diff
0005430: Add getter to return the base resource path Affected Issues
0005430
mod - test/TestContext.h Diff File

DarkRadiant: master b5e11cb7

2020-11-23 10:00:52

greebo

Details Diff
0005430: Add unit test checking if the active scheme is preserved from a (potentially) incomplete colours.xml.
Also, missing items need to be completed when upgrading.
Affected Issues
0005430
mod - radiantcore/settings/ColourSchemeManager.cpp Diff File
mod - test/ColourSchemes.cpp Diff File
add - test/resources/settings/colours_incomplete.xml Diff File

DarkRadiant: master 9e5e4e4c

2020-11-23 14:24:49

greebo

Details Diff
0005430: Add some tests covering the scheme loading from the user's colours.xml file Affected Issues
0005430
mod - test/ColourSchemes.cpp Diff File
add - test/resources/settings/colours_userdefined.xml Diff File

DarkRadiant: master ad22b400

2020-11-23 14:56:53

greebo

Details Diff
0005430: Add some tests covering deletion of user-schemes and the read-only status of saved schemes Affected Issues
0005430
mod - test/ColourSchemes.cpp Diff File

DarkRadiant: master b99b128e

2020-11-23 15:02:53

greebo

Details Diff
0005430: Add test cases covering GlobalColourSchemeManager().restoreColourSchemes() Affected Issues
0005430
mod - test/ColourSchemes.cpp Diff File

DarkRadiant: master 26b41da0

2020-11-23 15:09:25

greebo

Details Diff
0005430: Add test cases covering GlobalColourSchemeManager().foreachScheme() Affected Issues
0005430
mod - include/icolourscheme.h Diff File
mod - radiantcore/settings/ColourSchemeManager.h Diff File
mod - test/ColourSchemes.cpp Diff File

DarkRadiant: master ca2ebc1e

2020-11-23 15:11:49

greebo

Details Diff
0005430: Remove methods from public interface that should rather be internal Affected Issues
0005430
mod - include/icolourscheme.h Diff File
mod - radiantcore/settings/ColourScheme.h Diff File

DarkRadiant: master 52372f5c

2020-11-24 03:44:06

greebo

Details Diff
0005430: Remove _realised == true assertion from EClassManager since the ensureFinished() call will implicitly start the loader if it hasn't been started yet. Affected Issues
0005430
mod - radiantcore/eclass/EClassManager.cpp Diff File

DarkRadiant: master 67c635f1

2020-11-24 04:28:56

greebo

Details Diff
0005430: Add (currently failing) unit tests to check the world spawn wire shader Affected Issues
0005430
mod - test/RadiantTest.h Diff File
add - test/WorldspawnColour.cpp Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: master 2227fd5b

2020-11-24 11:12:21

greebo

Details Diff
0005430: Add EClassColourManager interface and implementing module which will deal with the colour overrides for certain entity classes. Affected Issues
0005430
add - include/ieclasscolours.h Diff File
mod - radiantcore/Makefile.am Diff File
add - radiantcore/eclass/EClassColourManager.cpp Diff File
add - radiantcore/eclass/EClassColourManager.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File
mod - tools/msvc/include.vcxproj Diff File

DarkRadiant: master 28485118

2020-11-24 11:17:56

greebo

Details Diff
0005430: Rip out the previous eclass colour handling code Affected Issues
0005430
mod - radiant/Makefile.am Diff File
rm - radiant/ui/EntityClassColourManager.cpp Diff File
rm - radiant/ui/EntityClassColourManager.h Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/ui/UserInterfaceModule.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: master 1994e933

2020-11-24 11:33:05

greebo

Details Diff
0005430: EClassManager is referencing the EClassColourManager to apply colour overrides Affected Issues
0005430
mod - include/ieclasscolours.h Diff File
mod - radiantcore/eclass/EClassColourManager.cpp Diff File
mod - radiantcore/eclass/EClassColourManager.h Diff File
mod - radiantcore/eclass/EClassManager.cpp Diff File
mod - radiantcore/eclass/EClassManager.h Diff File

DarkRadiant: master 77ebdae1

2020-11-24 11:53:14

greebo

Details Diff
0005430: Apply entity class colours each time the colour schemes are changed or loaded. Affected Issues
0005430
mod - include/ieclasscolours.h Diff File
mod - radiantcore/eclass/EClassColourManager.cpp Diff File
mod - radiantcore/eclass/EClassColourManager.h Diff File
mod - radiantcore/settings/ColourSchemeManager.cpp Diff File
mod - radiantcore/settings/ColourSchemeManager.h Diff File
mod - test/WorldspawnColour.cpp Diff File

DarkRadiant: master 21d391ef

2020-11-24 12:27:22

greebo

Details Diff
0005430: Add change signal to eclass::IColourManager Affected Issues
0005430
mod - include/ieclasscolours.h Diff File
mod - radiantcore/eclass/EClassColourManager.cpp Diff File
mod - radiantcore/eclass/EClassColourManager.h Diff File

DarkRadiant: master 8ab345cb

2020-11-24 12:51:03

greebo

Details Diff
0005430: Use the override colour changed signal to update the eclasses during runtime Affected Issues
0005430
mod - include/ieclasscolours.h Diff File
mod - radiantcore/eclass/Doom3EntityClass.cpp Diff File
mod - radiantcore/eclass/Doom3EntityClass.h Diff File
mod - radiantcore/eclass/EClassColourManager.cpp Diff File
mod - radiantcore/eclass/EClassColourManager.h Diff File
mod - radiantcore/eclass/EClassManager.cpp Diff File
mod - radiantcore/eclass/EClassManager.h Diff File

DarkRadiant: master ebdf19aa

2020-11-24 13:21:37

greebo

Details Diff
0005430: Better previewing when selecting colour schemes - call emitEclassOverrides explicitly by the ColoueSchemeEditor. Affected Issues
0005430
mod - include/icolourscheme.h Diff File
mod - radiant/uimanager/colourscheme/ColourSchemeEditor.cpp Diff File
mod - radiantcore/settings/ColourSchemeManager.cpp Diff File
mod - radiantcore/settings/ColourSchemeManager.h Diff File

DarkRadiant: master ceb7092e

2020-11-24 13:27:14

greebo

Details Diff
0005430: Unit test covering the revert/emit/save behaviour of eclass overrides Affected Issues
0005430
mod - test/WorldspawnColour.cpp Diff File

Issue History

Date Modified Username Field Change
23.11.2020 03:52 greebo New Issue
23.11.2020 03:52 greebo File Added: deep_xml_files_2.9.0.zip
23.11.2020 03:53 greebo Note Added: 0013012
23.11.2020 03:53 greebo Status new => acknowledged
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master 3212c01c
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master 45a1d67c
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master 117beb68
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master fd2fdce8
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master b5e11cb7
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master 9e5e4e4c
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master ad22b400
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master b99b128e
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master 26b41da0
23.11.2020 15:12 greebo Changeset attached => DarkRadiant master ca2ebc1e
24.11.2020 03:42 greebo Summary Corrupted Colour Schemes after upgrading to 2.9.x => World geometry is blue and cannot be changed when no worldspawn entityDef is defined
24.11.2020 03:42 greebo Description Updated View Revisions
24.11.2020 03:42 greebo Status acknowledged => confirmed
24.11.2020 03:42 greebo Assigned To => greebo
24.11.2020 03:42 greebo Status confirmed => assigned
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master 52372f5c
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master 67c635f1
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master 2227fd5b
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master 28485118
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master 1994e933
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master 77ebdae1
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master 21d391ef
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master 8ab345cb
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master ebdf19aa
24.11.2020 13:27 greebo Changeset attached => DarkRadiant master ceb7092e
24.11.2020 13:30 greebo Target Version => 2.9.2
24.11.2020 13:39 greebo Status assigned => resolved
24.11.2020 13:39 greebo Resolution open => fixed
24.11.2020 13:39 greebo Fixed in Version => 2.9.2
13.12.2020 06:22 greebo Fixed in Version 2.9.2 => 2.10.0
13.12.2020 06:22 greebo Target Version 2.9.2 => 2.10.0