View Issue Details

IDProjectCategoryView StatusLast Update
0005450DarkRadiantMap Editingpublic04.01.2021 06:38
ReporterIZaRTaX Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionduplicate 
PlatformPCOSWindows 7OS Versionx64
Product Version2.9.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0005450: Surface inspector "Natural" causes random stretch texture (2.10.0)
DescriptionSmall bug, sometime when you create a brush and hit natural button this is what happens > https://i.imgur.com/EvjkbOR.png
a long stretch texture even in the uv tool you'll not find it, looks like there's no texture on the brush

You have to hit the natural button twice to fix the problem never happened to me before in the older versions.
TagsGlitch, graphics

Relationships

duplicate of 0005474 resolvedgreebo Default scale & natural function producing stretched results 

Activities

Spooks

Spooks

02.01.2021 18:46

reporter   ~0013348

I can actually confirm this happening on 2.9.0 pre3, so it's older than 2.10.

Related Changesets

DarkRadiant: master 19939882

2021-01-04 06:35:22

greebo

Details Diff
0005474: Fix "Natural Texture" producing stretched results due to uninitialised members in ShiftScaleRotation structure. Affected Issues
0005450, 0005474
mod - include/ibrush.h Diff File

Issue History

Date Modified Username Field Change
19.12.2020 16:11 IZaRTaX New Issue
19.12.2020 16:11 IZaRTaX Tag Attached: Glitch
19.12.2020 16:11 IZaRTaX Tag Attached: graphics
19.12.2020 16:14 IZaRTaX Summary Surface inspector "Natural" causes stretch texture => Surface inspector "Natural" causes stretch texture (2.10.0)
19.12.2020 16:16 IZaRTaX Summary Surface inspector "Natural" causes stretch texture (2.10.0) => Surface inspector "Natural" causes random stretch texture (2.10.0)
19.12.2020 16:18 IZaRTaX Description Updated View Revisions
30.12.2020 10:28 Dragofer Relationship added related to 0005474
02.01.2021 18:46 Spooks Note Added: 0013348
04.01.2021 06:11 greebo Relationship replaced duplicate of 0005474
04.01.2021 06:12 greebo Status new => confirmed
04.01.2021 06:37 greebo Changeset attached => DarkRadiant master 19939882
04.01.2021 06:37 greebo Assigned To => greebo
04.01.2021 06:37 greebo Status confirmed => assigned
04.01.2021 06:38 greebo Product Version => 2.9.0
04.01.2021 06:38 greebo Target Version => 2.11.0
04.01.2021 06:38 greebo Status assigned => resolved
04.01.2021 06:38 greebo Resolution open => duplicate
04.01.2021 06:38 greebo Fixed in Version => 2.11.0