View Issue Details

IDProjectCategoryView StatusLast Update
0005471DarkRadiantMap Editingpublic05.01.2021 17:08
ReporterSpooks Assigned Togreebo  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0005471: Collapsing a brush while undoing cannot be undone
DescriptionA bit of a tongue twister so let me explain. When you drag a brush to 0 units it collapses unto itself and gets deleted. You can normally undo this with your regular Ctrl+Z'ing, BUT if you undo WHILE your brush dragging operation is in progress, the brush deletion will not go into the undo history and it will be lost forever.
Steps To ReproduceCreate a brush (A) and another brush (B).
Press the mouse button to drag-resize A in a view, ortho or 3D. Press Ctrl+Z while keeping the mouse button pressed.
B's creation gets undone. Drag-resize A so it gets collapsed. Depress the mouse button.
Press Ctrl+Y to redo. A does not come back, B does. A is gone forever.
Additional InformationIt does not matter if you collapse the brush before or after you undo, but you MUST collapse it. A simple change in size gets put in the undo history, you can reverse that under these reproduction steps. It's the deletion that you can't.
TagsNo tags attached.

Activities

greebo

greebo

05.01.2021 16:08

administrator   ~0013375

It's even crashing on my end, so this seems to be a really problematic combination of actions.
greebo

greebo

05.01.2021 17:08

administrator   ~0013376

Undo/Redo is now prevented in the middle of an operation

Related Changesets

DarkRadiant: master 6d2ea39b

2021-01-05 17:07:49

greebo

Details Diff
0005471: Prevent undo or redo in the middle of an active undoable operation. Affected Issues
0005471
mod - radiantcore/undo/UndoSystem.cpp Diff File

Issue History

Date Modified Username Field Change
29.12.2020 16:44 Spooks New Issue
29.12.2020 17:55 greebo Status new => acknowledged
05.01.2021 16:08 greebo Status acknowledged => confirmed
05.01.2021 16:08 greebo Note Added: 0013375
05.01.2021 16:08 greebo Severity normal => crash
05.01.2021 17:07 greebo Assigned To => greebo
05.01.2021 17:07 greebo Status confirmed => assigned
05.01.2021 17:07 greebo Target Version => 2.11.0
05.01.2021 17:08 greebo Changeset attached => DarkRadiant master 6d2ea39b
05.01.2021 17:08 greebo Status assigned => resolved
05.01.2021 17:08 greebo Resolution open => fixed
05.01.2021 17:08 greebo Fixed in Version => 2.11.0
05.01.2021 17:08 greebo Note Added: 0013376