View Issue Details

IDProjectCategoryView StatusLast Update
0005474DarkRadiantGUIpublic04.01.2021 06:54
ReporterBikerdude Assigned Togreebo  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Version2.9.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0005474: Default scale & natural function producing stretched results
DescriptionClicking on the default scale button results in a mis-scaled texture
Steps To Reproduce1. select a face on a brush
2. apply a texture
3. without touching the the figure in the default scale box click on the natural modify button

Above test done with fresh config files.
Additional Informationhttps://youtu.be/Ytgh0kLpbK8
TagsNo tags attached.

Relationships

has duplicate 0005450 resolvedgreebo Surface inspector "Natural" causes random stretch texture (2.10.0) 

Activities

greebo

greebo

04.01.2021 06:11

administrator   ~0013357

I can confirm this, it seems to happen in release builds only, that's why I had a hard time reproducing it. Let's see what I can do.
Bikerdude

Bikerdude

04.01.2021 06:53

reporter   ~0013358

Last edited: 04.01.2021 06:54

View 2 revisions

Thanks Greebo.

Related Changesets

DarkRadiant: master 19939882

2021-01-04 06:35:22

greebo

Details Diff
0005474: Fix "Natural Texture" producing stretched results due to uninitialised members in ShiftScaleRotation structure. Affected Issues
0005450, 0005474
mod - include/ibrush.h Diff File

Issue History

Date Modified Username Field Change
30.12.2020 10:15 Bikerdude New Issue
30.12.2020 10:16 Bikerdude Steps to Reproduce Updated View Revisions
30.12.2020 10:28 Dragofer Relationship added related to 0005450
04.01.2021 06:11 greebo Relationship replaced has duplicate 0005450
04.01.2021 06:11 greebo Status new => confirmed
04.01.2021 06:11 greebo Note Added: 0013357
04.01.2021 06:35 greebo Assigned To => greebo
04.01.2021 06:35 greebo Status confirmed => assigned
04.01.2021 06:37 greebo Changeset attached => DarkRadiant master 19939882
04.01.2021 06:38 greebo Product Version 2.10.0 => 2.9.0
04.01.2021 06:38 greebo Target Version => 2.11.0
04.01.2021 06:38 greebo Status assigned => resolved
04.01.2021 06:38 greebo Resolution open => fixed
04.01.2021 06:38 greebo Fixed in Version => 2.11.0
04.01.2021 06:39 greebo Summary Default scale & natural function broken: => Default scale & natural function producing stretched results
04.01.2021 06:53 Bikerdude Note Added: 0013358
04.01.2021 06:54 Bikerdude Note Edited: 0013358 View Revisions