View Issue Details

IDProjectCategoryView StatusLast Update
0005498DarkRadiantGeneralpublic29.01.2021 03:55
ReporterMirceaKitsune Assigned Togreebo  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSLinux openSUSEOS VersionRelease
Product Version2.11.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0005498: Crash when selecting caulk in Texture Browser, saving, loading map
DescriptionSome maps will instantly crash DR when opened. This happens because of that map's map.darkradiant file, and goes away when the following line is manually deleted from it (the MapProperties section):

KeyValue { "LastShaderClipboardMaterial" "textures/common/caulk" }
Steps To ReproduceEdit a map. In the texture browser (T window) select a texture, in this case caulk. Save your map. Close Darkradiant and open it again. Load your map from the file menu (recent maps section). DR will show the map but then freeze for a few seconds and crash.
TagsCrash

Relationships

related to 0005513 confirmed Change wxDataViewItem ID from TreeModel::Node* to something safer 

Activities

greebo

greebo

22.01.2021 03:47

administrator   ~0013490

Last edited: 22.01.2021 08:37

View 3 revisions

You don't happen to have a backtrace, by chance?

edit: nevermind, could repro the problem

Related Changesets

DarkRadiant: master a63aab98

2021-01-22 08:53:30

greebo

Details Diff
0005498: Fix crash in wxGTK due to the wxDataViewCtrl idle event processor running into a stale wxDataViewItem Affected Issues
0005498
mod - libs/wxutil/dataview/TreeView.cpp Diff File

Issue History

Date Modified Username Field Change
20.01.2021 00:11 MirceaKitsune New Issue
20.01.2021 00:11 MirceaKitsune Tag Attached: Crash
22.01.2021 03:47 greebo Status new => feedback
22.01.2021 03:47 greebo Note Added: 0013490
22.01.2021 03:47 greebo Note Edited: 0013490 View Revisions
22.01.2021 08:37 greebo Status feedback => confirmed
22.01.2021 08:37 greebo Priority high => normal
22.01.2021 08:37 greebo Severity major => crash
22.01.2021 08:37 greebo Note Edited: 0013490 View Revisions
22.01.2021 08:54 greebo Changeset attached => DarkRadiant master a63aab98
22.01.2021 08:54 greebo Assigned To => greebo
22.01.2021 08:54 greebo Status confirmed => assigned
22.01.2021 08:54 greebo Product Version 2.10.0 => 2.11.0
22.01.2021 08:54 greebo Target Version => 2.11.0
22.01.2021 08:54 greebo Status assigned => resolved
22.01.2021 08:54 greebo Resolution open => fixed
22.01.2021 08:54 greebo Fixed in Version => 2.11.0
29.01.2021 03:55 greebo Relationship added related to 0005513