View Issue Details

IDProjectCategoryView StatusLast Update
0005499The Dark ModMappingpublic25.01.2021 06:09
ReporterDragofer Assigned ToDragofer  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.08 
Target VersionTDM 2.09Fixed in VersionTDM 2.09 
Summary0005499: Prefabs house cleaning
DescriptionTDM has accumulated a lot of prefabs over the years. Inevitably some of them will have issues, i.e. their assets no longer exist or they've fallen below the current quality standard. The prefabs base would likely benefit from a systematic examination to make sure they're all fit for use by mappers.

Some possible considerations:
1) Move prefabs that are currently in the root folder into appropriate subfolders
2) Prefabs with (too many) missing assets should be excluded until they can be fixed
3) Some prefabs may be very crude and encourage poor or outdated mapping practices, especially as TDM's quality standards have evolved. So far I couldn't find any examples yet, though.
4) Some folder rearrangements may make sense, i.e. merge the architecture/fireplaces and fireplaces folders, move Springheels_modules_buildings into the architecture/modules folder or move skyboxes out of the nature folder and into the skybox folder. In the latter example, IIRC the A to Z Mapping Guide should be updated.
(not resolved) 5) Some prefabs have mapping issues, such as noticeable gaps in the mesh of small_round_furnace_openable.pfb.
6) DR 2.11's prefab preview is now oriented so that it looks north, corresponding to how it'll appear in top-down orthoview. Some prefabs may need to be re-exported with a new rotation so they can be previewed properly, such as most of the fireplaces.
7) Re-export off-center prefabs near 0,0,0 for the benefit of mappers with older DR versions than 2.11.

This ticket would keep track of any changes made to this end.
TagsNo tags attached.

Activities

Dragofer

Dragofer

22.01.2021 21:55

developer   ~0013491

Last edited: 22.01.2021 21:59

View 2 revisions

Rev 16109
1) Move prefabs that are in the root folder into appropriate subfolders. Exceptions due to no good match: market stalls. A couple useless prefabs were deleted outright.

For the market stalls, I'm considering making a new "clutter" top-level folder that would contain the current top-level folders junk, household_accessories and shelf_objects.
Dragofer

Dragofer

22.01.2021 22:38

developer   ~0013492

Rev 16110
1) Also move prefabs in the top-level of well-developed folders like Architecture and Decorative into appropriate subfolders. Furthermore, the market stalls have been allocated to the existing furniture/stalls folder.
Dragofer

Dragofer

23.01.2021 09:13

developer   ~0013494

Rev 16111
4) Improve folder organisation by merging and moving, see https://forums.thedarkmod.com/index.php?/topic/20746-prefabs-house-cleaning/&do=findComment&comment=455830 for details.
Dragofer

Dragofer

23.01.2021 11:37

developer   ~0013495

Last edited: 23.01.2021 17:36

View 3 revisions

Rev 16112
2) Identify prefabs with missing assets, try to fix, otherwise exclude for later fixing or delete if not worth saving. Mainly excluded some AI prefabs. Also, make the Kitchen folder lower-case, like all the other top-level folders.

Rev 16113
2) Also include the updated release manifest (rev 16112 was committed from the prefabs folder).
Dragofer

Dragofer

23.01.2021 17:33

developer   ~0013496

Rev 16114
3) Eliminate duplicates, very low quality prefabs and prefabs that rely on outdated mapping practices. Fix prefabs with obvious mistakes. Correct severe typos. Rename prefabs with unhelpful names.

Rev 16116
6) Make sure prefabs are generally rotated towards the preview camera, especially since DR 2.11's preview camera now points northwards to match top-down XY orthoview.

Rev 16117
2) For certain AI prefabs, track down & restore missing defs. Then unexclude the fixed prefabs.
Dragofer

Dragofer

23.01.2021 17:36

developer   ~0013497

I'll leave out "5) Fixing mapping issues", since looking closely at all prefabs ingame would take ages and is better left to routine bugtracker tickets opened by mappers. The other steps, in contrast, were surprisingly quick.
Setting to resolved.
Dragofer

Dragofer

23.01.2021 21:04

developer   ~0013498

Last edited: 25.01.2021 06:09

View 2 revisions

Rev 16118
6) For users on older versions of DR, make sure that prefabs are near to 0,0,0 so that they show up fully in the Prefab Chooser preview. This has been a longstanding problem that was solved in DR 2.11+.

Issue History

Date Modified Username Field Change
22.01.2021 20:53 Dragofer New Issue
22.01.2021 20:53 Dragofer Status new => assigned
22.01.2021 20:53 Dragofer Assigned To => Dragofer
22.01.2021 20:54 Dragofer Description Updated View Revisions
22.01.2021 20:55 Dragofer Description Updated View Revisions
22.01.2021 20:57 Dragofer Description Updated View Revisions
22.01.2021 21:26 Dragofer Description Updated View Revisions
22.01.2021 21:55 Dragofer Note Added: 0013491
22.01.2021 21:59 Dragofer Note Edited: 0013491 View Revisions
22.01.2021 22:38 Dragofer Note Added: 0013492
23.01.2021 09:13 Dragofer Note Added: 0013494
23.01.2021 11:37 Dragofer Note Added: 0013495
23.01.2021 11:45 Dragofer Note Edited: 0013495 View Revisions
23.01.2021 17:33 Dragofer Note Added: 0013496
23.01.2021 17:36 Dragofer Note Added: 0013497
23.01.2021 17:36 Dragofer Note Edited: 0013495 View Revisions
23.01.2021 17:37 Dragofer Status assigned => resolved
23.01.2021 17:37 Dragofer Resolution open => fixed
23.01.2021 17:37 Dragofer Product Version TDM 2.09 => TDM 2.08
23.01.2021 17:37 Dragofer Fixed in Version => TDM 2.09
23.01.2021 17:37 Dragofer Target Version TDM 2.10 => TDM 2.09
23.01.2021 17:37 Dragofer Description Updated View Revisions
23.01.2021 21:03 Dragofer Status resolved => feedback
23.01.2021 21:03 Dragofer Resolution fixed => reopened
23.01.2021 21:04 Dragofer Note Added: 0013498
23.01.2021 21:04 Dragofer Status feedback => resolved
23.01.2021 21:04 Dragofer Resolution reopened => fixed
25.01.2021 06:09 Dragofer Description Updated View Revisions
25.01.2021 06:09 Dragofer Note Edited: 0013498 View Revisions