View Issue Details

IDProjectCategoryView StatusLast Update
0005587The Dark ModSoundpublic20.04.2021 19:45
Reporternbohr1more Assigned Tonbohr1more  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.10Fixed in VersionTDM 2.10 
Summary0005587: Add setting to control EFX Reverb Strength
DescriptionSplit from 0004907

The default EFX reverb presets are often stronger than the preferred values for some players.

We should offer a setting to decrease the reverb volume

Daniel Gibson has added this feature to the DHewm3 port of Doom 3

https://github.com/dhewm/dhewm3/issues/365

https://github.com/DanielGibson/dhewm3/commit/ef42f004db74043c981b4c0a90b945b417c9cc09
TagsNo tags attached.

Relationships

child of 0004907 confirmed Make OpenAL settings more configurable inside TDM 

Activities

nbohr1more

nbohr1more

14.04.2021 03:59

developer   ~0013844

Rev 9264

s_alReverbGain now controls EFX Reverb master volume
stgatilov

stgatilov

14.04.2021 05:23

administrator   ~0013845

Somehow, you committed all the changes with spaces instead of tabs.

Did you apply some patch from external project automatically?
Because if you did it manually, you should check why your editor does not take .editorconfig into account.
stgatilov

stgatilov

16.04.2021 11:58

administrator   ~0013861

Converted spaces to tabs.
stgatilov

stgatilov

18.04.2021 06:04

administrator   ~0013873

Did anyone actually requested the reverb control slider?
I'm okay with having a cvar, but not sure a slider is needed...
nbohr1more

nbohr1more

18.04.2021 12:16

developer   ~0013875

I don't recall any recent requests for this but I vaguely recall older discussions around it.

If the slider is bothersome, feel free to remove it or let me know if you want me to remove it.
kingsal

kingsal

20.04.2021 19:44

developer   ~0013883

Last edited: 20.04.2021 19:45

View 2 revisions

We should be diligent about not changing any of the actual room settings and just reducing the reverb "gain" otherwise this slider will change the intended effect.

Issue History

Date Modified Username Field Change
14.04.2021 03:27 nbohr1more New Issue
14.04.2021 03:27 nbohr1more Status new => assigned
14.04.2021 03:27 nbohr1more Assigned To => nbohr1more
14.04.2021 03:27 nbohr1more Relationship added child of 0004907
14.04.2021 03:59 nbohr1more Note Added: 0013844
14.04.2021 03:59 nbohr1more Status assigned => resolved
14.04.2021 03:59 nbohr1more Resolution open => fixed
14.04.2021 03:59 nbohr1more Fixed in Version => TDM 2.10
14.04.2021 04:04 nbohr1more Description Updated View Revisions
14.04.2021 05:23 stgatilov Note Added: 0013845
16.04.2021 11:58 stgatilov Note Added: 0013861
18.04.2021 06:04 stgatilov Note Added: 0013873
18.04.2021 12:16 nbohr1more Note Added: 0013875
20.04.2021 19:44 kingsal Note Added: 0013883
20.04.2021 19:45 kingsal Note Edited: 0013883 View Revisions