View Issue Details

IDProjectCategoryView StatusLast Update
0005641DarkRadiantRendererpublic29.06.2021 19:16
ReporterAluminumHaste Assigned Toorbweaver  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.12.0 
Target Version2.13.0Fixed in Version2.13.0 
Summary0005641: Non power of 2 textures show up black in
DescriptionUsing non power of 2 dimensions, such as 2048x1536, in DarkRadiant's render view, it shows up as black, but works just fine in TDM.
Additional InformationI've attached the offending DDS texture (have not checked if TGA/JPG have the same problem), as well as the Material file. You can just drop the dds in Darkmod\dds\textures\darkmod\carpet\runners
And the mtr file in Darkmod\materials
TagsNo tags attached.

Activities

AluminumHaste

AluminumHaste

07.06.2021 16:43

updater  

Muse-Starlight.png (484,676 bytes)
ornate_black_white_HD_d.dds (4,194,480 bytes)
tdm_carpetHD.mtr (10,298 bytes)   
//=========================================================rugs===========================================================
//Author: Aluminumhaste
textures/darkmod/carpet/rugs/base_carpet_HD
{
    surftype15
    description "carpet"
    
    qer_editorimage textures/darkmod/carpet/rugs/base_carpet_ed
    diffusemap      textures/darkmod/carpet/rugs/base_carpet_d
    bumpmap         textures/darkmod/carpet/rugs/base_carpet_local
	//specularmap			textures/darkmod/carpet/rugs/base_carpet_s

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/rugs/base_carpet_d
        rgb         0.15 * parm11
    }
}

//Author: Aluminumhaste
textures/darkmod/carpet/rugs/carpet_simplepattern_HD
{
    surftype15
    description "carpet"
    
    qer_editorimage textures/darkmod/carpet/rugs/carpet_simplepattern_ed
    diffusemap      textures/darkmod/carpet/rugs/carpet_simplepattern_d
    bumpmap         textures/darkmod/carpet/rugs/carpet_simplepattern_local
	//specularmap		textures/darkmod/carpet/rugs/base_carpet_s

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/rugs/carpet_simplepattern_d
        rgb         0.15 * parm11
    }
}


textures/darkmod/carpet/rugs/ornate_green_black01_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/rugs/ornate_green_black01_HD_ed
    diffusemap      textures/darkmod/carpet/rugs/ornate_green_black01_HD_d
    bumpmap         textures/darkmod/carpet/rugs/ornate_green_black01_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/rugs/ornate_green_black01_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/rugs/ornate_vines_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/rugs/ornate_vines_ed
    diffusemap      textures/darkmod/carpet/rugs/ornate_vines_HD_d
    bumpmap         textures/darkmod/carpet/rugs/ornate_vines_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/rugs/ornate_vines_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/rugs/ornate_red_tan01_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/rugs/ornate_red_tan01
    diffusemap      textures/darkmod/carpet/rugs/ornate_red_tan01_HD_d
    bumpmap         textures/darkmod/carpet/rugs/ornate_red_tan01_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/rugs/ornate_red_tan01_HD
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/rugs/ornate_red_tan02_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/rugs/ornate_red_tan02_HD_ed
    diffusemap      textures/darkmod/carpet/rugs/ornate_red_tan02_HD_d
    bumpmap         textures/darkmod/carpet/rugs/ornate_red_tan02_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/rugs/ornate_red_tan02_HD_d
        rgb         0.15 * parm11
    }
}

//=========================================================runners========================================================

textures/darkmod/carpet/runners/ornate_blue_white_end_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/runners/ornate_blue_white_end_HD_ed
    diffusemap      textures/darkmod/carpet/runners/ornate_blue_white_end_HD_d
    bumpmap         textures/darkmod/carpet/runners/ornate_blue_white_end_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/ornate_blue_white_end_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/runners/ornate_blue_white_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/runners/ornate_blue_white_ed
    diffusemap      textures/darkmod/carpet/runners/ornate_blue_white_HD_d
    bumpmap         textures/darkmod/carpet/runners/ornate_blue_white_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/ornate_blue_white_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/runners/geometric01_red_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/runners/geometric01_red_ed
    diffusemap      textures/darkmod/carpet/runners/geometric01_red_HD
    bumpmap         textures/darkmod/carpet/runners/geometric01_red_local_HD

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/geometric01_red_HD
        rgb         0.15 * parm11
    }
}


textures/darkmod/carpet/runners/geometric01_red_end_HD
{
    surftype15
    description "carpet"
    
    qer_editorimage textures/darkmod/carpet/runners/geometric01_red_end_ed
    diffusemap      textures/darkmod/carpet/runners/geometric01_red_end_HD_d
    bumpmap         textures/darkmod/carpet/runners/geometric01_red_end_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/geometric01_red_end_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/runners/geometric02_red_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/runners/geometric02_red_ed
    diffusemap      textures/darkmod/carpet/runners/geometric02_red_HD_d
    bumpmap         textures/darkmod/carpet/runners/geometric02_red_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/geometric02_red_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/runners/geometric02_red_end_HD
{
    surftype15
    description "carpet"

    qer_editorimage textures/darkmod/carpet/runners/geometric02_red_end_ed
    diffusemap      textures/darkmod/carpet/runners/geometric02_red_end_HD_d
    bumpmap         textures/darkmod/carpet/runners/geometric02_red_end_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/geometric02_red_end_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/runners/ornate_red_black03_end_HD
{
    surftype15
    description "carpet"
    
    qer_editorimage textures/darkmod/carpet/runners/ornate_red_black03_end_ed
    diffusemap      textures/darkmod/carpet/runners/ornate_red_black03_end_HD_d
    bumpmap         textures/darkmod/carpet/runners/ornate_red_black03_end_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/ornate_red_black03_end_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/runners/ornate_black_white_end_HD
{
    surftype15
    description "carpet"
    
    qer_editorimage textures/darkmod/carpet/runners/ornate_black_white_end_HD_ed
    diffusemap      textures/darkmod/carpet/runners/ornate_black_white_end_HD_d
    bumpmap         textures/darkmod/carpet/runners/ornate_black_white_end_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/ornate_black_white_end_HD_d
        rgb         0.15 * parm11
    }
}

textures/darkmod/carpet/runners/ornate_black_white_HD
{
    surftype15
    description "carpet"
    
    qer_editorimage textures/darkmod/carpet/runners/ornate_black_white_HD_ed
    diffusemap      textures/darkmod/carpet/runners/ornate_black_white_HD_d
    bumpmap         textures/darkmod/carpet/runners/ornate_black_white_HD_local

    {
        if ( parm11 > 0 )
        blend       gl_dst_color, gl_one
        map         _white
        rgb         0.40 * parm11
    }
    {
        if ( parm11 > 0 )
        blend       add
        map         textures/darkmod/carpet/runners/ornate_black_white_HD_d
        rgb         0.15 * parm11
    }
}
tdm_carpetHD.mtr (10,298 bytes)   
AluminumHaste

AluminumHaste

07.06.2021 18:45

updater   ~0014072

Uploaded the editor image file also
ornate_black_white_HD_ed.jpg (22,240 bytes)   
ornate_black_white_HD_ed.jpg (22,240 bytes)   
orbweaver

orbweaver

07.06.2021 20:17

developer   ~0014073

Reproduced the problem. It seems to be specific to the DDS format; converting to a TGA and saving into textures/... rather than dds/textures/... results in correct rendering. Not confirmed whether the problem is caused by image dimensions or something else.
orbweaver

orbweaver

07.06.2021 20:20

developer   ~0014074

Resized the DDS to 2048x1024 and it renders fine, so it does appear that NPOT dimensions are the problem.
AluminumHaste

AluminumHaste

07.06.2021 20:29

updater   ~0014075

Shit, I forgot to mention that I tried that already and it works.
orbweaver

orbweaver

29.06.2021 19:15

developer   ~0014135

Fixed in dbcaf84578c9e1fda9896dc8c4dcb021bbc14cad

Issue History

Date Modified Username Field Change
07.06.2021 16:43 AluminumHaste New Issue
07.06.2021 16:43 AluminumHaste File Added: Muse-Starlight.png
07.06.2021 16:43 AluminumHaste File Added: ornate_black_white_HD_d.dds
07.06.2021 16:43 AluminumHaste File Added: tdm_carpetHD.mtr
07.06.2021 17:15 greebo Status new => acknowledged
07.06.2021 18:45 AluminumHaste Note Added: 0014072
07.06.2021 18:45 AluminumHaste File Added: ornate_black_white_HD_ed.jpg
07.06.2021 20:16 orbweaver Assigned To => orbweaver
07.06.2021 20:16 orbweaver Status acknowledged => assigned
07.06.2021 20:17 orbweaver Note Added: 0014073
07.06.2021 20:20 orbweaver Note Added: 0014074
07.06.2021 20:29 AluminumHaste Note Added: 0014075
29.06.2021 19:15 orbweaver Status assigned => resolved
29.06.2021 19:15 orbweaver Resolution open => fixed
29.06.2021 19:15 orbweaver Fixed in Version => 2.13.0
29.06.2021 19:15 orbweaver Note Added: 0014135
29.06.2021 19:16 orbweaver Target Version => 2.13.0